
    
Step-by-Step Tutorials

It’s time to jump into the database fast lane! By the time you finish the lessons in this tutorial you’ll have a
solid foundation in the basic techniques you’ll need to use Panorama effectively.

This tutorial is divided into three lessons. Each lesson builds on the previous lessons and introduces more
advanced topics. In “Lesson 1: Building Your First Mailing List Database” on page 2 you’ll learn how to cre-
ate and set up a simple mailing list database. In “Lesson 2: Building and Organizing a Checkbook” on
page 75 you’ll not only build a simple checkbook register file but also learn several techniques for organizing
and summarizing the checkbook data. In “Lesson 3: Building an Invoice Database” on page 158 you’ll create
a simple invoice for creating and tracking orders. Finally, in “Lesson 4: Building a Price List” on page 175
you’ll create a price list and link it to the invoice database. Each lesson should take from 30 minutes to an
hour to complete. The lessons are designed so you can easily follow along and actually build each database as
you read. There are plenty of illustrations to show what the screen will look like at each step, so you don't
need to worry about getting lost. 

Before you begin, you’ll need to install Panorama on your computer. If you haven’t done so already, see
“Installing the Software” on page 85. It’s not necessary to activate Panorama to complete the operations in
this tutorial. If you haven’t purchased Panorama yet you can try out the tutorials before you decide that you
want to purchase Panorama (see “Using Panorama’s “Demo Mode”” on page 104).

I hear the bell—class is about to begin. It’s time to get started with your new Panorama career! I hope you
have as much fun learning Panorama as we had creating it for you.

Sincerely,
  

Jim Rea, President

P.S. This tutorial teaches you how to work with Panorama. It assumes, however, you already are familiar with
your computer and operating system. You should be able to point, click, and drag selections, and be able to
make selections from menus, use scroll bars, and edit text. If you are not familiar with these skills, you should
review the tutorial information supplied with your computer.



 

Page 2 Panorama Handbook

           
Lesson 1: Building Your First Mailing List Database
Mailing List

A mailing list for storing names and addresses is one of the most basic database applications, and is very sim-
ple to create with Panorama. Start by launching Panorama and the New Database Wizard. On Windows sys-
tems you can do this with the Start menu, on Macintosh systems you’ll use the Apple menu.

Your new mailing list database will have seven fields — First, Last, Address, City, State, Zip and Phone. (See
“Fields” on page 327 for a complete explanation of fields.) Type in the name of each field into the wizard,
with each name on a separate line (press the Return key to advance to the next line).

type in field names
then press this button to create the database
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When you press the Make New Database button the wizard will create a new database for you. The database
is displayed using a row and column format called the data sheet. The new database contains one blank
record (line) and seven fields (columns).

Entering Data Into Your New Database

The new database is ready to use immediately — you can just start typing to enter data. For example, to enter
the name Bob simply start by pressing the b key. A small pop-up window will appear over the current cell.
This pop-up window is called the Input Box and is used for all data entry in the data sheet(see “The Input
Box” on page 376).

Complete the entry of the name by pressing ob. Notice that Panorama automatically capitalized the first
letter of the name. We’ll show you how to turn this feature on and off later (see “Automatic Capitalization”
on page 385 if you can’t wait).

When you’ve finished with the first name press the Tab key to move on to the last name.
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Continue typing and pressing the Tab key until you get to the phone number. When you tab into the Phone
field you’ll notice that Panorama automatically types in the ( for you.

The New Database Wizard has set up an Input Pattern to make typing the phone number easier (see “Input
Patterns” on page 393). All you have to type is the numbers, for example 7024879023. Pan-
orama will type in the punctuation for you.

Once you’ve finished entering the phone number you have a choice to make. Press the Tab key if you want to
add another line and continue editing data.

Press Return or Enter if you are done with data entry for the moment.

Panorama types in (, ), space and - for you
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Making Corrections

It’s easy to change the contents of any cell. Start by double clicking on the cell. This opens the Input Box,
allowing you to type in a new value or to make corrections.

Press the Enter key or click on another cell when you are finished. (You can also press the Tab key if you want
to skip to next cell and edit it too.)

Editing a Multi-Line Cell

If you need more room to enter your data, you can expand the size of the Input Box. For example, you might
need to expand the Input Box to enter an address with more than one line. To expand the Input Box, move the
arrow to the lower right hand corner of the box. When the mouse reaches the corner, the arrow will flip over
so that it is pointed down instead of up.

When you see the arrow flip over, press the mouse and drag the corner of the box to the size you want.

double click to edit cell

mouse “flips over” in lower right hand corner
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When you release the mouse the Input Box will expand to the new size.

Now that the Input Box has been expanded you can use the Return key to add additional lines to the data
cell. You can add as many lines as you like.

When you are finished editing the address press the Enter key. The Input Box closes and now you can only
see the first line of the data. (If you want to see more than one line of data in a cell that is not being edited you
must use a form, see “Displaying and Editing Text” on page 637).

If you double click to edit the data cell again Panorama will remember the new size of the Input Box.

only first line of text is visible in data sheet
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You can adjust the size of the Input Box any time it is open.

If the Input Box is less than one inch high it won’t have a scroll bar.

To learn more about expanding the Input Box see “Expanding the Input Box” on page 377

Saving Your Work

To permanently store your new database choose the Save command from the File menu.
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Using the dialog, choose the folder you want to save the database in. Type in the name of the file and check
the Save Window Positions option (see “Saving Window Positions” on page 213). When everything is set up
press the Save button.

If you are using a Windows PC the dialog looks a little bit different but the procedure is exactly the same.

select folder you want to save file in

type in name of file

tell Panorama to save window positions

Type in name of file

select folder you want to save file in

tell Panorama to save window positions
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After the file is saved the name of the window will change from Untitled to the name of the file, in this case
My Mailing List.

Importing Data Into the Mailing List

If you already have data in another program (FileMaker, Access, Excel,etc.) you can transfer that data to Pan-
orama by exporting it into a text file (tab or comma delimited) and then importing it into Panorama. Pan-
orama includes some text files with sample data, so we’ll import one of those files now. Start by choosing Text
Import Wizard from the Wizards menu.

The wizard opens and lists the fields in your database on the right hand side.

name of database data will be imported into

fields in database
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The next step is to select the text file that contains the data to be imported. Choose Select Text File from the
File menu inside the window.

Using the dialog, locate the file 200 Sample People.txt in the Sample Data folder. When you have located the
file press the Open button.

Once the file is selected the wizard will display the fields in the first line of the text file. The text file contains
15 fields, including name, address, phone, fax, email and birthday (not shown).

name of text file being imported

first line of data in text file
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Before you can import the data you must assign the fields in the text file to fields in the database. Start by
dragging Barbara to the First field.

When you release the mouse the wizard will assign the second field from the text file to the First field.

Drag each of the text fields you want to import onto the corresponding database field. You can check your
work by looking at the Sample Data column.

second field of text file assigned
to this database field
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Once all of the fields are set up choose Import Data from the File menu inside the window.

The wizard will import the data from the text file into the database.

Your database now contains 201 records — the single record you typed in plus the 200 records imported by
the Text Import Wizard. The total number of records is displayed in the lower left hand corner of the window.

Before you go any further you should use the Save command (in the File menu) to save the new data in the
database. Since you have already saved this file once and given it a name, Panorama will quickly save the file
without asking you for the name and location again.

Since we’re done with the Text Import Wizard for the moment, click on it’s window to bring it forward and
then close the window.

To learn more about the Text Import Wizard see “Using the Text Import Wizard” on page 234.

total number of records in the entire database
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Adjusting Column Widths, Font and Size

To adjust the width of a column in the data sheet move the mouse anywhere over the column name. When
the mouse is over the name it will turn into a double left/right arrow.

To adjust the column width press and drag to the left or right.

When you release the mouse the column width will be adjusted.

mouse turns into double left/right arrow
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You can use this technique to adjust the widths of as many columns as you like (see “Changing the Width of
a Field” on page 331).

Use the Text menu to change the font and size of the text displayed in the data sheet.

When you change the size of the text Panorama changes with width of each column proportionally, so that
you do not need to adjust the widths of the columns.

Use the Save command (File menu) to save the new configuration.
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Sorting the Database

Now that the database is filled with sample data you can try out Panorama’s commands for organizing data.
To sort by zip code start by clicking anywhere in the Zip column.

Now choose Sort Up from the Sort menu.

click anywhere in this column
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Panorama will sort the database as soon as you release the mouse. Notice that the zip code you originally
clicked on is still highlighted. If you want to see the first zip code you’ll need to use the vertical scroll bar to
move to the top of the database.

Sorting By Two or More Fields

You can sort by as many fields as you like. In this example you will sort by cities within states. The first step
is to sort by states. To do this click anywhere in the State field and choose Sort Up from the Sort menu.

click anywhere in State field… then Sort Up
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Now the database is sorted by state, but the cities within each state are still out of order. For example, Hialeah
should be the first state within Florida (FL) and Atlanta should be the first city within Georgia (GA).

To sort the cities within the states first click anywhere in the City field, then choose Sort Up Within from the
Sort menu. Be sure to choose Sort Up Within, not Sort Up.

click anywhere in the City field… then Sort Up Within
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The database is still sorted by state, but now the cities are sorted within each state as well.

You can use Sort Up Within as many times as you wish in your database. For example, you could now sort
the last names within each city. To learn more about sorting see “Sorting” on page 425.

Finding a Person

To search for someone’s last name in the database you first need to click somewhere in the Last column.

Now choose the Find/Select command from the Search menu.
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Type some or all of the name you wish to find into the dialog. In this case we what to search for Gutierrez so
we will enter the first few letters of the name. (The more of the name you type in the less chance there will be
for a false match with someone else.)

When you press the Find button Panorama will locate Ms. Gutierrez.

Finding Multiple People

Suppose you want to look up someone who’s first name is Alan, but you’re not sure what the last name is.
Start by clicking anywhere in the First column.

(2) press Find button

(1) enter some or all of name you want to find
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Now choose the Find/Select command and type in the name Alan.

When you press the Find button Panorama will find the first person named Alan in the database.

If this isn’t the Alan you were looking for choose Find Next from the Search menu.

Panorama will skip to the next Alan in the database.

You can continue using the Find/Next command until you have located every Alan in the database.

Selecting Instead Of Finding

Another way to locate every person named Alan is to select the information (see “Finding vs. Selecting” on
page 433). To do this click in the First column and choose the Find/Select command, but press the Select but-
ton instead of the Find button.
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Most of the database will disappear. In fact, only the records containing the first name Alan will remain visi-
ble (selected). Everything else is temporarily invisible. Panorama displays the number of selected records in
the lower left hand corner of the window. In this case five records contain the first name Alan. We say that
these five records are the selected records. The other 196 records are invisible (unselected).

Using the Sounds Like Option

If you don’t know exactly how something is spelled you can try using Panorama’s sounds like option. To use
this option open the Find/Select dialog and use the middle pop-up menu to select Sounds Like. (Shortcut:
You can open the Find/Select dialog by clicking on the number of records in the lower left hand corner.)

five selected records contain the name Alan
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Here’s what the dialog looks like after you make this selection.

Panorama now selects six records instead of five, because the name Allen “sounds like” Alan.

The sounds like option isn’t perfect, but it can find most similar sounds and spellings. You must, however,
know the first letter of the word or name you are looking for. For example, the sounds like option will never
think that the name Ellen sounds like Alan because the two names start with different letters.
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Making More Complex Selections

The Find/Select dialog can be expanded to allow more complex selections. For example, suppose you want
to select all people with zip codes from 50000 to 69999. Start by clicking on the Zip field, then open the Find/
Select dialog. Click the pink arrow (shown below) to expand the dialog to allow up to six simultaneous selec-
tions.

Use the pop-up menus to fill in the first two lines of the dialog, like this.

click here to
expand/shrink dialog
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When you press the Select button Panorama will select only the records in the requested zip code range, in
this case 20 records.

Panorama can also make complex selections based on a formula. To do this use the Formula Find/Select com-
mand in the Search menu.

Here is the formula for selecting zip codes in the range from 50000 to 69999.

Here is a formula that will select unusually long last names (more than 10 characters).
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When you press the Select button Panorama will select the five people in this database with extra-long last
names.

To learn more about selecting with a formula see “Formula Find/Select” on page 447 and “True/False For-
mulas” on page 1282.

Selecting All Records

To make all of the invisible data re-appear choose Select All from the Search menu.

Panorama will display all of the data in the database again.
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Adding A Database To Your List Of Favorites

You can use Panorama’s Favorite Databases wizard to help organize your databases and keep then accessi-
ble at your fingertips. To open this wizard choose Favorite Databases from the Wizards menu.

The wizard displays a list of favorite databases on the left. If you click once on a database the wizard will
show you information about that database. (Clicking twice opens the database itself.)

To add your new database to the list of favorites choose Add “My Mailing List” from the File menu inside
the window.
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The wizard will add your new database to the list of favorites.

Use the pop-up menu to move the mailing list into the My Tutorials group.

Choose the Save command in the File menu and your database is permanently added to the list of favorites
(see “Removing a Favorite Database” on page 193 if you later want to remove this favorite).

Closing a Database

To close a database click on it (to bring it’s window to the front). If the database has only one window you can
close it by clicking on the window’s close box. If the database has more than one window you can close each
window individually or you can select the Close File command from the File menu. Close the My Mailing
List database now.
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If the database has been modified since the last time it was saved Panorama will ask you if you want to save
the changes. Press the Save button to save the changes.

The database is now closed, and the memory it was using is available for use with other databases. See “Mon-
itoring Memory Usage” on page 267 to learn how to oversee Panorama’s memory usage.

Re-Opening a Favorite File

To re-open a favorite file, start by choosing the Favorite Databases wizard from the Wizards menu. If the
database was assigned to a group you can find it quickly with the Group menu inside the window.

Right now the My Tutorials group only contains a single file, your new mailing list.
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Double click the database name to open it.

To learn more about this wizard see “The Favorite Databases Wizard” on page 191. Tip: If you hold down the
Control key (Mac) or double click with the right mouse button (Windows PC) Panorama will automatically
close the Favorite Databases window after it opens the selected database.

Printing the Data Sheet

Before actually printing the data sheet you’ll set up a page header to print today’s date on the top left and the
page number on the top right of each page. To do this choose Headers/Footers from the File menu.
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This command opens a dialog that allows you designate headers on the top left, center and right and a bot-
tom centered footer.

Start with the top left header. Type in the words Printed on and then press the Month dd, YYYY button.

type Printed on

then press button
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Now for the top right header. Type Page and then press the Page#  button.

Once both headers are set up press the OK button. (To learn more about the header and footer options avail-
able when printing the data sheet see “Printing Data Sheet Headers & Footers” on page 1056. When printing
a form you have complete control over the exact layout of headers and footers — see “Custom Reports” on
page 1067.)

Next, choose the Page Setup command from the File menu. (Before you do this, make sure that the printer
you want to use is connected to your computer and selected.) The exact options available in the Page Setup
dialog depend on the operating system and what kind of printer you are using, but in general you can control
the page size, orientation (tall or wide), and print reduction factor. Here is a typical Page Setup dialog.

type Printed on

then press button
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Select the printing options you want to use and press the OK button. To actually print the data sheet choose
Print from the File menu. The printing dialog will appear. The exact options available in this dialog depend
on the operating system and what kind of printer you are using, but in general you can control which pages
to print, how many copies to print, and whether you want to manually feed the paper. Here is a typical Print
dialog.

For the exact details on the operation of this dialog see the documentation that came with your printer. Press
the Print button to print the data sheet. Panorama will automatically print as many sheets as necessary.

If you want to print only a portion of the database, use the Select button in the Find/Select dialog to select
the data you want before printing the database (see “Selecting Instead Of Finding” on page 20). Only the vis-
ible records will be printed.
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Creating a Form for Printing Mailing Labels

Now let’s create a mailing label. Many types of peel-off labels are available commercially. Panorama already
knows the dimensions of many popular labels and can do most of the work for you. The first step in setting
up a mailing label is to create a form to hold the label. A form is like a sheet of paper that you can draw on
(see “Introduction to Forms” on page 539). You can place graphics, text and data on the form to create labels,
invoices, statements, or virtually anything else. To create a new form select New Form from the View menu.

A dialog box appears asking for more information about the new form you want to create. Type in a name for
the new form (we used the name Mailing Labels, but you can choose any name up to 25 characters long).

The dialog gives you three options when creating a new form — a blank form, a mailing label and a report.
Press the Quick Label button. The Quick Label dialog appears, allowing you to define the dimensions of the
mailing label you want to print on.
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In the center of the dialog is a pop-up menu that lists many popular labels. The most popular label is the
Avery 5160 which contains 30 labels per page in three columns of 10 labels.

When you release the mouse the updated label dimensions appear. (You may also see an alert telling you that
the Larger Page Area option must be set in the Page Setup dialog. If you see this message you should make
sure Page Setup is configured to use as much of the page as possible, with the minimum possible margins.)

Press the OK button after the dimensions are set up.
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Once the label dimensions are set up, the next step is to set up the text that will be printed on the label. A sec-
ond dialog box will appear with a list of fields on the left. You’ll build the template for your label on the right.

Start by double clicking on the First field, then press the Space Bar.

Now double click on the Last field, then press the Return key.

Double click on the Address field, then press the Return key.

˙

¥

¥
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Double click on the City field, then press the comma key and the Space Bar.

Finish the label by double clicking on the State field, pressing the Space Bar and then double clicking on the
Zip field.

You can choose the font and size you want to use now or later.

Press OK when the label design is complete.

, ˙

˙
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Panorama now shows you the finished template for the label. The label appears on special “tiles” that control
the size and spacing of the labels (see “Tiles In Action” on page 1081).

Previewing the Labels

To see how the page of labels would look before printing, choose Preview from the File Menu. If this is the
first time the labels have been previewed or printed, the Page Setup dialog will appear. If this happens, just
press OK to skip to the preview window.

tile

tile

tile
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The Print Preview window will show a reduced view of an entire page of labels.

You can click on the magnifying glass tool to see the report life-size, and click on the Next Page tool to pre-
view the next page.

When you are done looking at the preview, click on the window’s close box. To learn more about the Print
Preview window see “Print Preview” on page 1063.
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Printing the Labels

To print your mailing labels, first make sure that the correct printer is selected. Make sure the labels are set up
in the printer, then choose Print from the File Menu.

If you don’t want to print all of the labels, use the Find/Select command to select the addresses you do want
to print. Use the Select button so that only the addresses you want to print are visible (see “Selecting Instead
Of Finding” on page 20). Once the correct addresses are selected, use the Print command to print the labels.
After the labels are printed, use the Select All command (see “Selecting All Records” on page 25) to make all
of the addresses visible again.

Switching Between Forms and the Data Sheet

To switch back to the data sheet select Data Sheet from the View menu.
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Panorama will switch the window from the mailing label back to the data sheet.

The pop-up View Menu lists every possible view of your database, and also allows you to create new views.
To switch back to the mailing label, choose the name of the form containing the label from the menu.

Your database can contain many different forms, each displaying the data a different way (see “Introduction
to Forms” on page 539).

Creating a Data Entry Form

A form is not limited to displaying and printing data, it can also be set up for data entry. Using a form allows
you to lay out the fields any way you like. You are not limited to the row and column format used by the data
sheet. 

To create a new form view you’ll use the View menu. You’re going to create the form in a new window. To do
this you must hold down the Alt key if you are using a Windows PC, if you are using a Macintosh hold down
the Control key. Either way, select New Form from the View menu.
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Panorama will ask you for the name of the new form. You can use any name you like up to 25 characters, we
chose the name Entry.

When you press the Blank Form button Panorama will create a new, empty, form. Since you pressed the Alt
key (PC) or the Control key (Mac) when using the View menu, Panorama creates the form in a new window,
leaving the data sheet also open in the back (see “Opening More Than One Window Per Database” on
page 303).

The tool palette on the left side of the window contains tools for creating and manipulating graphic objects on
the form. The most commonly used tools are shown below.

data sheet
blank form

switch between graphics editing and data editing
pointer for selecting graphic objects
turn cross hair on/off (to help alignment)
magnify/reduce
create data cell object (database field)
create text object
create line object
create rectangle object
create rectangle object with round corners
create oval/circle object
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Creating Graphic Objects

Before you actually start creating the data entry form let’s practice a bit with using these tools. Start by select-
ing the Oval tool.

Now move the cursor onto the form and drag the mouse across the surface of the form to define the location
and size of the new object (the dragging motion is shown by the dashed arrow in the illustration below). A
gray outline of the new object will follow the mouse.

When you release the mouse, the new object will appear.
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Each time you drag across the form you will create a new shape. Create several shapes as shown below (these
objects are just for experimentation, so don’t worry about the exact position and size).

When you are finished creating shapes, click on the Pointer tool.

Don’t forget to click on the Pointer tool when you are done! If you don’t, the next time you click you will
create another graphic object. To learn more about creating graphic objects see “Creating a Graphic Object”
on page 552.

Selecting and Moving a Graphic Object

To select a graphic object simply click on it with the Pointer tool selected. Four “handles” appear at the cor-
ners to show that the object is selected (see “Selecting a Single Object” on page 558).

click on the object you want to select

handles
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To move an object click on it and drag to the new position (see “Moving a Single Object” on page 564).

For fine adjustments you can use the arrow keys (¯, ˘, ¿, ˜) to nudge selected objects into position.
Each time you press an arrow key, the object (or objects) moves one pixel in the direction of the arrow (see
“Nudging an Object (or Objects)” on page 565).

Adjusting the Size of a Graphic Object

To change the size of an object, first select the object with the Pointer tool. Then use the mouse to drag one of
the corner handles. As you drag the handle, an outline of the object will follow the mouse.
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Release the mouse when the corner is in the correct spot (see “Changing the Size of a Single Object” on
page 568).

The arrow keys (¯, ˘, ¿, ˜) usually nudge the entire object. However, after you click or drag a handle,
the arrow keys will nudge just that handle. Each time you press an arrow key the handle will move one pixel
in the direction of the arrow. In other words, each time you press an arrow key the object will grow (or
shrink) one pixel in the direction of the arrow (see “Nudging the Size of an Object” on page 568). You can also
adjust the position and size of the object numerically with a dialog, see “Viewing and Setting Exact Object
Dimensions” on page 567 to learn how.
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Changing an Objects Appearance

The new objects you have created are white with a black border. You can use the Graphic Control Strip (on
the bottom of the window next to the horizontal scroll bar, see “The Graphic Control Strip” on page 562) to
change the appearance of the selected objects. To change the selected object to solid black use the fill pattern
menu (see “Fill Pattern” on page 575). This menu has 40 different patterns to choose from.

After you make your selection the object will change to the selected pattern, in this case solid fill.

current fill pattern (solid white)

solid black
solid whitetransparent

50% gray
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To change the color of the selected object use the color menu (see “Color” on page 580).

After you make your selection the object will change to the selected color.

You can also adjust the line pattern (see “Line Pattern” on page 577) and the line width (see “Line Width” on
page 579) of the selected object(s).

current fill pattern (black)
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Creating Text Objects

To add a piece of text to your form start by clicking on the Text tool.

Now move the mouse to the position where you want the text to appear (you can adjust the position later)
and click the mouse.

Now use the keyboard to type in the text.

As you type each character, the click text object automatically expands. To add another line of text press the
Return key. When you’re done creating text you can click on another spot to create another text object or you
can click on the Pointer tool.

click where you want the text to appear
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The text object you just created is called click text, because you click to create it. Panorama has another type
of text object called an auto-wrap text object. Instead of expanding automatically as you type an auto-wrap
text object is a fixed size, with the text wrapping inside the object. To create an auto-wrap text object click on
one corner of where you want the object to appear and then drag to the opposite corner.

When you release the mouse a dotted box appears for you to type into. 

Whatever you type will wrap inside of the box.

When you’re done creating text you can click or click-drag on another spot to create another text object or you
can click on the Pointer tool.
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Changing the Font and Size

To change the font and size of the selected object you can use the Graphic Control Strip or you can use the
Text menu (see “Text Font, Size and Style” on page 643). The illustration below shows the auto-wrap text
object being changed from 12 point to 9 point.

Here’s the revised text object.

Within a single text object all of the text must be the same font, size, style and color. If you want to mix differ-
ent text appearance within a single object you must use Panorama’s Word Processor SuperObject (see “Word
Processor SuperObject” on page 720).

current text size
current font
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Editing a Text Object

To edit a text object simply select the Text tool and click or drag on the object (see “Editing Fixed Text” on
page 640). With this tool you can edit the text object just like any other text - click to select an insertion point,
double click to select a word, etc.

Creating Data Cell Objects

Panorama has two different types of objects for editing data (see “Types of Data Editing Objects” on
page 682). Right now you’re going to learn about data cells, which allow data fields to be edited with a pop-
up input box very similar to the data sheet (see “Entering Data Into Your New Database” on page 3 and “The
Input Box” on page 376). To create a data cell start by selecting the Data Cell tool (see “Working with Data
Cell Objects” on page 685).

Drag the mouse across the form in the spot where you want to create the data cell.



Page 52 Panorama Handbook
When you release the mouse the data cell is created. It is automatically assigned to the first field in the data-
base, which in this database is First.

Each additional data cell you create will be assigned to the next available field in the database.

To change the field a data cell is assigned to make sure the Data Cell tool is selected and move the mouse
over the data cell object. When the mouse is over the object the arrow turns into a little menu icon.

When you se this icon you can press the mouse button to see a pop-up menu of the fields in the database.
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Select the field you want assigned to the data cell from the pop-up menu.

Panorama has another type of graphic object for editing data - the Text Editor SuperObject. To learn more
about this type of object see “Text Editor SuperObject” on page 689.

Aligning Multiple Objects

I don’t know about you, but those raggedy looking data cells are really bothering me! Fortunately Panorama
has tools that can make this objects nice and neat in a hurry. Start by selecting the Pointer tool.

Now start on an empty spot on the form and drag the mouse diagonally across all four objects. The dotted
rectangle should surround the objects.

When you release the mouse all four objects will be selected (see “Selecting Multiple Objects at Once” on
page 559).



Page 54 Panorama Handbook
To align the left and right edges of the objects choose Align Objects from the Arrange menu (see “Aligning
Objects” on page 605). The dialog gives you eight different alignment choices — pick Left & Right.

When you press the Align button the left and right edges of the objects are brought into perfect alignment.

To set the height of all of the objects to 15 pixels choose Dimensions from the Edit menu (see “Setting Exact
Dimensions of Multiple Objects” on page 602). Select the Pixels radio button and type in 15 for the height
(just 15, not +15).

When you press OK all of the objects will be adjusted to 15 pixels.
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To vertically space the objects evenly choose the Spacing command from the Arrange menu (see “Adjusting
Spacing Between Multiple Objects” on page 608). Click on the Vertical option and set the spacing you want
between each object (a pixel is one screen dot, or 1/72nd of an inch).

The data cells are now lined up nice and neat.

Before we call it a day let’s make one final adjustment. Hold down the Shift key and drag the bottom right
handle of the bottom object to the right.

When you release the mouse all four objects will expand. This feature is called cluster resize (see “Cluster
Resize” on page 593 for additional examples) and is very handy for adjusting columns of objects.

In a few minutes you’ll learn a method to create data cell objects in a nice neat column or row in the first
place, making the technique shown above unnecessary. However, you’ll still find the techniques described
above useful in many circumstances.
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Using Data Cells to Edit Data

So far you’ve managed to make four boxes with field names on them — perhaps that doesn’t seem very use-
ful. To activate these cells you must switch the form from Graphic Design Mode to Data Access Mode.

In this mode the rulers disappear and the tool palette switches from graphics tools to data navigation tools
(see “Moving From Record to Record” on page 369 and “Browsing the Database With a Form” on page 546).
Most importantly, the data cells now display information from the database itself.

database fields
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If you adjust the windows so that you can see both the data sheet and the form you can see that the form is
displaying the same information that the data sheet is displaying.

If you double click on one of the data cells you can edit the data, just as you could in the data sheet (see
“Entering Data Into Your New Database” on page 3 and “The Input Box” on page 376).
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When you press the Enter key the new data will appear in both the form and the data sheet.

The same process works in reverse also — any data you enter into the data sheet will also appear in any
forms that are open.

Building the Data Entry Form

Enough practice — it’s time to start building the actual data entry form. Start by switching the form back to
Graphic Design Mode.
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We’re going to start over in this form, so the first step is to erase all of the practice objects you have created. To
do that choose Select All Objects from the Edit menu, then Clear from the Edit menu (or press the Delete
key). Now you’ve got an empty form.

Now click the mouse in the upper left hand corner of the form, about 1/16th of an inch from the top and left
hand sides.

Now choose the Auto Cell Layout command from the Arrange menu. This command is going to create a neat
column of data cells for us (see “Automatically Creating Rows or Columns of Data Cells or Text Editor Super-
Objects” on page 709).
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This dialog controls how the data cells are generated. Start by pressing the Select All Fields button. Then set
the Spacing (Pixels) option to 1.

When you press the OK button Panorama will automatically create a column of data cells (starting at the
point where you clicked the mouse).

All of the objects are selected. To begin working on the objects separately click on any blank spot to de-select
the objects.
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Using a combination of dragging and the arrow keys (¯, ˘, ¿, ˜) move the objects so that the First and
Last name objects are on the same line and the City, State and Zip objects are the same line. Usually the best
technique is to drag the object approximately into place and then use the arrow keys to nudge it exactly into
position. If you need to review the techniques for dragging and nudging objects see “Moving a Single Object”
on page 564 and “Nudging an Object (or Objects)” on page 565. You may also find “Viewing and Setting
Exact Object Dimensions” on page 567 useful.

When you are finished the result should look like this.

Next drag and nudge the Phone object up under the City, State and Zip objects. When you drag the Phone
object hold down the Shift key so that Panorama will drag the object straight up with no slip to the left or
right (see “Moving a Single Object” on page 564). Then use the ¿ and ˜ arrow keys to nudge it into final
position.
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Again holding down the Shift key, drag the lower right hand handle to the right, expanding the width of the
Phone object.

Then use the ¯ and ˘ arrow keys to nudge the width of the object until it matches the combined width of
the City, State and Zip objects. You may find it useful to use the crosshair cursor to check the alignment (see
“Nudging to the Crosshair Cursor” on page 570).

Then use the same techniques to adjust the width of the Address cell. Alternatively you can select the
Address and Phone objects (see “Selecting Multiple Objects at Once” on page 559) and then use the Align
command with the Left & Right option to adjust the width. Either way the form should now look like this.

Drag the mouse around the bottom group of objects to select them (see “Selecting Multiple Objects at Once”
on page 559).
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While holding down the Shift key drag these objects up underneath the First and Last objects.

After you’ve dragged them close use the ¿ and ˜ arrow keys to nudge the objects into final position.

Finally drag and nudge the width of the Last name object to match the other objects.

As one last enhancement you’ll set the background color of the form. To do this use the Form Preferences
command in the Setup menu. The background color is set with a pop-up menu at the bottom of this dialog
(see “Form Background Colors” on page 633).
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Your new form is now complete. Use the Switch To Data Access Mode tool to prepare for displaying and
entering data, and adjust the window size and position so that both the data sheet and form are visible at the
same time.

The form window has a tool palette and scroll bars that aren’t really necessary. To get rid of them select the
Window Tweak command from the Wizard menu (see “Turning Window Components On and Off (Window
Tweak Wizard)” on page 283).
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The tool palette and scroll bars are now removed.

If you ever need to get the scroll bars and tool palette back again (for example to modify the form) simply
select the Window Tweak command again. Another option is to close the form window and then re-open it
with the View menu, which will also restore the tools and scroll bars.

Now that the form is complete be sure to Save your work. (In fact it really would have been a good idea to
save two or three times while you were working on the form. Since Panorama saves so quickly there’s no rea-
son not to save early and often.) Panorama saves the window positions along with the data and graphics
(assuming you checked the Save Window Positions option when you originally saved the file, see “Saving
Window Positions” on page 213), so if you close the file and then re-open it the form window and data sheet
windows will reappear in the same places, ready to go.



Page 66 Panorama Handbook
The new form you have created only scratches the surface of the capabilities available for building forms. To
see a more sophisticated example use the Favorite Databases wizard to open the 106th Congress database.
This form uses what is called view-as-list mode, which allows a form to display more than one record at a
time (kind of a cross between the data sheet and a regular form. See “View-As-List Forms” on page 917 to
learn how to create this type of form.

To see an example of a more traditional form press the Contact Info or Bio button. (See “Push Buttons” on
page 853 to learn how to create a button.) Pressing either button opens a form in a new window.

All of these forms use Flash Art to display a photograph (see “Flash Art™” on page 806). You can also show
and play a QuickTime movie in a form (see “Displaying Movies in a Form” on page 850).
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Linking the Mailing List with the Mini-Correspondence Wizard

Panorama includes a pre-built database for handling general word processing chores — the Mini Correspon-
dence wizard (see “Using the Mini Correspondence Wizard” on page 776). This database may be used for
general correspondence (letters, memos, etc.) and to create mail merge letters that are customized and sent to
a group of recipients. The Mini Correspondence wizard can be linked with any other database that contains
names and addresses (see “Linking Mini Correspondence to Other Databases” on page 785), so let’s link it
with your new mailing list. Start by choosing Mini Correspondence from the Wizard menu.

Choose Set up link to "My Mailing List" to start setting up the link.
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This dialog allows you to specify which fields in the mailing database match corresponding fields in the cor-
respondence database (see “Linking Mini Correspondence to Other Databases” on page 785).

Because the field names in your mailing list match the field names in the correspondence database all you
have to do is press the Automatic Formulas button. (If the names did not match you would have to click on
the triangles to use pop-up menus to select the corresponding fields.)

Press the OK button to complete the configuration, then close the Mini Correspondence database. The wiz-
ard actually stored the new configuration as part of your mailing list database, so Save the mailing list data-
base now.
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Writing a Letter to Someone in the Mailing List

Once the link is set up you can easily write a letter to anyone in your mailing list file. Start by locating the per-
son you want to write the letter to (for example Sharon Blair) and then choose Mini Correspondence from
the Wizards menu.

The wizard will ask you if you want to create a new letter to Sharon Blair.

click on the person you want to write a letter to
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Press the Yes button to create the new letter. The wizard will automatically fill in the name and address in the
new letter.

At this point all you need to do is type in the body of the letter. Just start typing.
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When you are finished typing in the letter press the Enter key. Panorama will display a preview of the actual
letter, including the address, greeting and salutation.

If you want to print this letter use the Print This Letter… command in the Letter menu (inside the window).

To learn more about editing a word processing document (including setting margins, tabs, fonts, styles and
colors) see “Using the Word Processor” on page 724.
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Printing a Mail Merge Letter

You can take the same letter you just created and send it to multiple recipients — for example we could send
it to everyone in the 619 area code. Start by going back to the My Mailing List database and selecting the
members of congress from California (see “The Find/Select Dialog” on page 435).

As you can see there are 4 people in this area code in the mailing list.

Now go back to the Mini Correspondence database and pull down the Letter menu. The last item in this
menu will print a customized letter to each selected person in the My Mailing List database.
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The wizard will print 4 customized letters.

See “Printing a Mail Merge Letter” on page 782 to learn more about printing mass mailings with Panorama.
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Tidying Up

Your mailing list database is complete, so now is the time to save your work permanently. Choose Quit from
the File Menu.

If you have made any changes to your database since the last time it was saved, Panorama will ask you if you
wish to save the database. You do, so click the Save button.

Congratulations! You’ve successfully created and used your first Panorama database (you were following
along on your computer, right?). Now that you’ve mastered the basics you’re ready to move on to some more
advanced techniques.
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Lesson 2: Building and Organizing a Checkbook
Checkbook

Now that you’ve created your first simple mailing list database, you’re ready to try something more compli-
cated. In this lesson you’ll build and use a database for keeping track of a checkbook. Start by launching Pan-
orama and the New Database Wizard. On Windows systems you can do this with the Start menu, on
Macintosh systems you’ll use the Apple menu.

The checkbook database will have eight fields — Date, Check, Pay To, Category, Memo, Debit, Credit and
Balance. (See “Fields” on page 327 for a complete explanation of fields.) Type in the name of each field into
the wizard, with each name on a separate line. The four numeric fields have special suffixes. The Check field
has a suffix of # to tell the wizard to create an integer numeric field (1, 2, 3, etc.). The Debit, Credit and Bal-
ance fields have a suffix to create a 2-digit numeric field (12.34, 813.94, 8.43 etc.). (Note: These suffixes are
only used when creating databases with the New Database Wizard (see “Creating Numeric and Date Fields”
on page 205). When creating fields with the Add Field command (see “Add Field” on page 329) or the Design
Sheet (see “The Design Sheet” on page 332) you can use any field name with any field type you like.)

# for integer fields

$ for money fields
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When you press the Make New Database button the wizard will create a new database for you. The database
is displayed using a row and column format called the data sheet. The new database contains one blank
record (line) and eight fields (columns). 

The eighth column, Balance, is not visible. To make it visible reduce the text size to 9 pt.

Now all of the columns are visible within the window.
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Loading the Data

To demonstrate Panorama’s organizational features you’ll need to type in a bunch of data. That doesn’t
sound like much fun, does it? Didn’t think so. To help you out we’ve created a database that is programmed
to automatically fill your new checkbook database with sample data. Start by choosing Favorite Databases
from the Wizard menu (see “The Favorite Databases Wizard” on page 191).

The database you need is called Sample Checkbook. To locate it, choose Search… from the Group menu (see
“Searching for a File” on page 199). You can also press Command-F (Macintosh) or Control-F (Windows).

Type in some or all of the name Sample Checkbook.

The wizard will show you a short list of files including the one we want.
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Double click on the Sample Checkbook file to open it. A small window will appear briefly. The database has
been pre-programmed to automatically transfer one year’s worth of sample checkbook data into the new
database you have created.

You may want to adjust the widths of some of the columns (see “Adjusting Column Widths, Font and Size”
on page 13).

Before continuing you should use the Save command in the File menu to save your new creation. The first
time you save any file Panorama will ask you to give it a name. You’ll also want to check the Save Window
Positions option (see “Saving Window Positions” on page 213). When everything is set up press the Save but-
ton. (To see what this dialog looks like on the PC see “Saving Your Work” on page 7.)

You may also want to add your new file to the Favorite Database wizard. See “Adding A Database To Your
List Of Favorites” on page 26 for a refresher on how to do this.

select folder you want to save file in

type in name of file

tell Panorama to save window positions
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Analyzing the Checkbook

In the next few sections you’ll learn several techniques for extracting useful information from any database. 

Selecting Data

To select all office supply expenditures, click anywhere in the Category column.

Next, choose Find/Select from the Search menu. (You can also open the Find/Select dialog by clicking on the
number of records in the lower left hand corner of the window). Type office supplies.

When you press the Select button (or the Enter key) Panorama will select the 73 checks for office supplies in
the database. All of the other checks will become temporarily invisible.
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To select only the office supply expenditures in October 1998, re-open the Find/Select dialog. Click on the
pink arrow in the bottom left corner of the dialog. This expands the dialog, allowing you to specify up to six
selection criteria.

Use the pop up menus to change the second line to Date and Equal, then type in oct 98. When you want to
select an entire month you must spell out the month, for example nov 02 or january 1997. You can also select
a single day, for example 3/7/96 or August 15, 2001 (see “Locating Dates by Month, Quarter, or Year” on
page 438).
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Press the Select button (or the Enter key) to see the 8 checks for office supply expenses in October 1998.

When you want to see all of the checks again, choose Select All from the Search menu. You can also undo the
sixteen most recent selections with the Undo command in the Edit menu (see “Undo Select” on page 443).

Calculating the Grand Total

To calculate the grand total of all the checks in the database start by clicking anywhere in the Debit column.

Next, choose the Total command from the Math menu.

Panorama will add a new record to the end of the database. This new record is called a summary record (see
“Summary Records” on page 323), and it contains the grand total for all the checks.

summary records displayed with + symbol on left side grand total
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As you can see the column isn’t quite wide enough to display the entire grand total. You can drag on the col-
umn name to adjust the width (see “Adjusting Column Widths, Font and Size” on page 13).

When you are finished looking at the grand total use the Cut Record tool to delete it (or press the Delete key,
see “Deleting a Record” on page 373).

Calculating Subtotals

To calculate the grand total you created a single summary record at the end of the database. To calculate sub-
totals you must create a summary record for every category you want to subtotal. This is done with the
Group Up command in the Sort menu. As an example you’ll create subtotals for each month, and sub-subto-
tals for each category within each month. Start by clicking anywhere in the Date column and choosing Group
Up from the Sort menu.



Page 83
Since the field being grouped contains dates, Panorama will ask what time period you want to use. The
Month option is already selected, so just press Group.

At first it may appear that nothing has happened. However, if you scroll the database down you will see that
Panorama has created a summary record after each month. It also creates an extra summary record at the bot-
tom of the database for the grand total. You can identify summary records easily because— 1) they are bold,
and 2) they have a little plus sign to the left of the first column.

summary record for January  1998

summary record for February  1998

summary record for March  1998

summary record for April  1998

summary record for grand total
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Now click anywhere in the Category column, then choose Group Up from the Sort menu. Panorama will cre-
ate a summary record after each category within each month.

summary record for January  1998
summary records for categories within January

summary record for February  1998
summary records for categories within February

summary record for March  1998
summary records for categories within March

summary record for March  1998
summary records for categories within March

summary record for grand total
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Once the summary records are set up, you’re ready to actually calculate the subtotals. Click anywhere in the
Debit column and choose Total from the Math menu. The Total command will calculate a grand total, subto-
tals for each month, and subtotals for each category within each month.

subtotal for January  1998

Jan utilities

Jan telecom

Jan shipping

subtotal for February  1998

Feb utilities

Feb telecom

subtotal for March  1998 

Mar utilities

Mar telecom

Grand Total 

Mar utilities

Mar telecom

subtotal for December  1998 
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Hiding and Showing Detail

It’s difficult to get a feel for the subtotals when they are mixed in with the raw data. To collapse the database
so that only the monthly totals are visible, choose the Outline Level command in the Sort menu.

The Outline Level dialog shows how you have grouped the data. At the top is the raw data, all 515 records.
The next level is the Category, then the monthly summaries. At the bottom level is the grand total. To collapse
the database so that only the monthly totals are visible, press the 2 button.
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When you press the button the database collapses so that only the twelve monthly totals and the grand total
are visible. Everything else is hidden. You can quickly see that March was the month with the highest spend-
ing and July the month with the lowest spending.

Why was the spending almost 22,000 dollars in March? To find out, click anywhere on the March summary
record.

Now click on the Expand tool.
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The Expand tool reveals the next level of detail, in this case the Category summaries for the month of March.

To see the actual checks that make up a particular category, just click on the category and then choose the
Expand tool again.

Now the actual checks are visible for each purchase in March.
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If you want to hide the detail again use the Collapse tool.

To learn more about expanding and collapsing summaries see “STEP 3 - OUTLINE” on page 469.

Sorting Summaries by Value

Summary records are normally sorted alphabetically by category, but you can resort them by value to pro-
duced a ranked list from highest to lowest. As an example we’ll sort the Category subtotals within each
month to find out the highest spending categories in each month. Start by choosing the Outline Level com-
mand from the Sort menu, then press the 1 button.
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Now both the monthly and category summaries are visible, but the raw data is not visible. The category sum-
maries are sorted alphabetically within each month (the window has been expanded to show three months
worth of data).

Now click anywhere in the Debit column, then choose Sort Down from the Sort menu. We’re using Sort
Down instead of Sort Up because we want the largest values at the top.

click on Debit field before sorting
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Within each month, the Category subtotals are now sorted by value from highest to lowest. Now you can eas-
ily see that payroll is the largest spending category in each month. Rent and advertising are consistently near
the top, while telecom and utilities are consistently near the bottom.

If you’d like to see more detail about a particular summary just click on it and press the Expand tool.
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When Panorama sorted the summary records by value it also moved the corresponding data records so that
you can expand to see the detail. Within each summary the data records have not been sorted by value, they
are still sorted in their original order (by date).

To learn more about sorting summary values see “Sorting Within Groups” on page 482.
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Removing Summary Records

Summary records are designed to be temporary. When you are done examining the summary records you
need to remove them to restore the database to it’s original state. To do this choose the Remove Summaries
command from the Sort menu. As you can see from the illustration, it doesn’t matter whether the summary
records are expanded or collapsed when you choose this command.

The Remove Summaries dialog allows you to delete some or all of the summary records in the database.
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Since you want to remove all of the summary records press the Remove All Summaries button (or press the
Enter key). This removes all of the summary records and leaves only the original data records. (If you want to
learn how and why you would delete only some of the summary records see “Getting Rid of Summary
Records” on page 482).

Although the summary records are gone, the database still isn’t quite back to its original state. Instead of the
entries being sorted by date they are still sorted by category within each month. To get back to the original
order click anywhere in the Date field and choose Sort Up from the Sort menu.
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The database still isn’t quite back in the original order. Originally the check numbers were sorted within each
day.

To fix this problem click anywhere in the Check column and choose Sort Up Within (see “Sorting By Two or
More Fields” on page 16).
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Now all of the data is back to its original order.

With a little bit of advance preparation you can make it much simpler to restore the original database order
after grouping summary records (assuming that you care what order the records are in — in many cases you
won’t. One technique would be to Save the database just before using the Group command, and then use the
Revert to Saved command when you are done (see “Revert to Saved” on page 214). Another technique
would be to create an extra field and fill the field with a numeric sequence (1, 2, 3, etc.) using the Sequence
command (see “Automatic Numbering” on page 522). After you remove the summaries you can simply sort
by this numeric field to restore the original order.
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Automating Tasks with Procedures

Right out of the box, Panorama is a very flexible program. Its built in menus and tools bring incredible power
to your fingertips. Even better, you can easily create your own commands that can be activated with a menu
or button. You can create these commands (called procedures) using Panorama’s built in programming lan-
guage or simply by recording each step with the built in recorder. To start recording a procedure just click on
the Record Procedure tool. The wheels of the recorder will start to spin to let you know that Panorama is
recording your actions (see “Creating a Procedure with the Recorder” on page 1353).

Your job is to create procedures that automate the summary process you just learned. With the recorder run-
ning (make sure the reels are spinning) perform the following steps (the same steps you just performed, see
“Calculating Subtotals” on page 82).

When you’ve finished with these steps press the Record Procedure tool again. This stops the recording.

Step Action

1 Click on the Date field.

2 Choose Group Up from the Sort menu.

3 Choose the Month option.

4 Click on the Group button.

5 Click on the Category field.

6 Choose Group Up from the Sort menu.

7 Click on the Debit field.

8 Choose Total from the Math menu.

9 Choose Outline Level from the Sort menu.

10 Click on the 2 button.
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After you stop the recorder a dialog box will appear. Type in the name of the new procedure (in this case
Month & Category Totals) and press the Create Procedure button.

Next you’ll create another procedure to remove the summaries and restore the original order of the data (see
“Removing Summary Records” on page 93). Start by turning the recorder back on again.

With the recorder running perform the following steps.

When you’ve finished with these steps press the Record Procedure tool again to stop the recording.

Panorama will ask you to give this procedure a name of its own.

Before you go any further you should Save your database with the new procedures you just created.

Step Action

1 Choose Remove Summaries from the Sort menu.

2 Click on the Remove ALL Summaries button.

3 Click on the Date field.

4 Choose Sort Up from the Sort menu.

5 Click on the Check field.

6 Choose Sort Up Within from the Sort menu.
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Using the Action Menu

If you look closely you’ll see that a new menu has appeared — the Action menu. This menu contains the two
procedures you just recorded.

When you choose a command from this menu it replays the steps that were recorded in the procedure.
Choose the Month & Category Totals command now. Panorama replays the 10 steps in this procedure as fast
as it can — zip zip zip.

Now choose the Restore Original Data command to quickly remove the summary records and restore the
original data order.

To learn more about the Action menu see “The Action Menu” on page 1442.
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Editing a Procedure

To see what is inside a procedure open the procedure with the View Menu.

The window switches from the Data Sheet to show the procedure. Each command you recorded appears in a
simple English-like format.

Panorama has hundreds of commands that can be used in a procedure — in fact, it has a complete program-
ming language. The fundamentals of this programming language are described starting with “Introduction
to (Panorama) Programming” on page 1345.
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When you used the Month & Category Totals procedure you may have noticed that the screen flashed over
and over again as the commands were performed. By editing the procedure to add two new commands you
can eliminate the extra unnecessary flashing. Edit the procedure to add the two new commands shown in the
illustration below.

To try out the revised procedure you’ll need to use the View menu to switch back to the Data Sheet.

To try out your revised procedure choose it from the Action menu.

You’ll notice that the procedure now runs with a minimum of extra flashing. (Actually, on a fast machine it
may be a bit difficult to tell the difference for a procedure as short as this, but it can make a big difference with
a slower machine or a longer procedure.)

Before moving on to the next step in the tutorial you choose the Restore Original Data command and then
the Save command in the File menu to save the revised procedure.
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Analyzing Data with a Crosstab

In addition to the Group command Panorama has another powerful tool for summarizing data — crosstabs.
For your next trick you’ll create a crosstab table that displays spending by category vs. month. To create a
new crosstab view you’ll use the View menu. If you are using a Windows PC hold down the Alt key, if you
are using a Macintosh hold down the Control key. Either way, select New Crosstab from the View menu.

Type in the name of the new crosstab, in this case Monthly Spending, and then press the OK button.

Panorama will create the new crosstab window, and then immediately open the Crosstab dialog. This dialog
contains a list of the database fields on the left hand side. On the right hand side is a list of fields in the
crosstab and a diagram of the crosstab layout (both empty to start).

diagram of
crosstab layout
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To tell Panorama to list months across the top of the crosstab click on Date and then press the »Copy» button
(or double click on Date).

To separate the crosstab into one month per column use the pop-up menu to switch from Day to Month.
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Next you need to specify the field that will appear down the left hand side of the crosstab table. Click on Cat-
egory and then press the »Copy» button (or double click on Category).

Next you must specify what goes in the middle of the crosstab table. Click on Debit and then press the
»Copy» button (or double click on Debit).

Finally, click the Total radio button so that the crosstab will add up the checks instead of counting them.
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Press the OK button. Panorama will think for a few seconds, then the crosstab table will appear in a new win-
dow slightly below and to the right of the data sheet window (see “Opening More Than One Window Per
Database” on page 303). The crosstab table displays a summary of the information in the database, showing
categories down the left hand side and months across the top (see “Crosstabs” on page 493).

Just as with the Data Sheet you can adjust the text size and column widths of the crosstab table (see “Adjust-
ing Column Widths, Font and Size” on page 13).
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You can split the window into two separate panes by dragging the splitter to the right. The splitter is the
small black rectangle to the left of the horizontal scroll bar (see “Splitting a Window” on page 278).

Once the window has been split in two you can horizontally scroll each pane separately. If you scroll all the
way to the right you will see the overall totals for each category.

To learn more about crosstabs see “Crosstabs” on page 493.

totals for each category
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Auditing the Crosstab Table

As you examine a crosstab you may find that you need to check out the backup detail behind a certain num-
ber. Doing this is easy—just click on the number and then click the Select Original Data tool. For example,
suppose you want to see the individual checks written for purchases in November of 1998. Simply click on
the Nov 98 Purchases cell and click on the tool.
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After you click on the tool the data sheet shows the detail for the crosstab cell you clicked on, in this case the
nine checks made for purchase in November of 1998.
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You can use the Select Original Data tool with any cell in the crosstab. In this illustration it has been used to
select all Fixed Assets regardless of month.
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If you click on one of the cells in the bottom line and use the Select Original Data tool Panorama will select
an entire month of checks, in this case all 43 checks written in February of 1998.

When you are done with the crosstab close the window and, if necessary, use Select All in the Search menu to
make all the records in the data sheet visible again (see “Selecting All Records” on page 25). You can open the
crosstab again later using the View menu.

If the data has changed use the Calculate Crosstab tool to re-calculate the table values.

To learn more about crosstabs see “Crosstabs” on page 493.
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Making a Bar Chart

Someone once said that a chart is worth a thousand numbers. Ok, that’s not quite what they said, but let’s
create a chart anyway. Charts are usually displayed from summary records in the database (see “Calculating
Subtotals” on page 82). These can be created with the Group and Total commands you learned about before.
They can also be created with the Summary & Outline Wizard. To open this wizard choose Summary &
Outline Wizard from the Wizard menu.

The wizard contains eight pop-up menus that allow you to specify how to summarize the database.
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We’ll make a chart to display spending per month, so choose Date (by Month) from the first Group pop-up
menu.

Using the pop-up menus set the first Total option to Debit and the Outline Level to Date (by Month).
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When these three options are set up press the Summarize button. Panorama will group, total, and collapse
the database just as if you had performed these operations manually (see “Calculating Subtotals” on page 82
and “Hiding and Showing Detail” on page 86). To learn more about this wizard see “The Summaries & Out-
lines Wizard” on page 483.

The next step in building a chart is to create a new form. If you are using a Windows PC hold down the Alt
key, if you are using a Macintosh hold down the Control key. Either way, select New Form from the View
menu (see “Creating a New Form” on page 545).

You know the drill by now — type in the name of the new form (up to 25 characters).
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Press the Blank Form button to create the new form.

Adjust the window size to approximately the size of the chart you want to make, then click on the Chart tool.
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Move the mouse over the form and then drag from corner to corner to create the chart, just as you would to
create a rectangle or a data cell.

Your new chart doesn’t look much like a chart yet, in fact it looks more like a dialog!
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The buttons and pop-up menus in the dialog allow you to configure the chart. At a minimum, you must
select a legend field and at least one value field (see “Setting Up Legend and Value Fields” on page 1006). In
this case the legend field is already set to Date. Use the pop-up menu to set the value field to Debit.

Switch to Data Access Mode to see the actual chart (see “Form Modes: Data Access vs. Graphic Design” on
page 543).

legend field

value field
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Customizing the Chart Appearance

Let’s dress up the chart a little bit. To do that switch back to Graphic Design Mode (see “Form Modes: Data
Access vs. Graphic Design” on page 543). Then click on the chart and change the font size to 9 point.

Now select the Output Pattern command from the Text menu.
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This command allows you to specify how the dates in the chart legend will be displayed. To display just the
abbreviated month name (Jan, Feb, Mar, etc.) type in Mon (see “Date Output Patterns” on page 361).

Use the color pop-up menu to select a different color for the chart bars (see “Graphic Attribute Icons” on
page 1025).

Click on the Grid option to display a dotted line from each tick mark.
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To preview the chart’s appearance without going into Data Access Mode click on the preview flap in the
lower left hand corner of the chart object. The preview flap is the small triangle that looks like a turned up
page corner.

When in the preview mode you can use the extra fifth chart handle to adjust the margin where the chart leg-
ends appear.

preview flap
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When the form is switched to Data Access Mode the chart will immediately show any changes made to the
database.



Page 121
For example if you edit the summary value for March 1998 the chart will immediately update to reflect that
change (of course it usually doesn’t make any sense to edit a summary value like this). In the illustration
shown below the summary value has been increased from 21908.19 to 27908.19.

We’re finished with the chart, so close the window. Choose Restore Original Data from the Action menu,
then Save the database. To learn more about charts see “Charts” on page 1001.
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Data Entry Helpers

Now let’s switch gears. Before you can analyze data you have to get the data into the database, and that usu-
ally means data entry with the keyboard. This job is never easy, but Panorama does have tools that can make
data entry faster and less error prone. The next few sections will look at how the data entry process can be
improved for each of the fields in the checkbook database.

Dates

The first field in the database contains the check date. You can modify the database to default to today’s date
when a new check is created. Start by clicking anywhere in the Date field and then choose the Field Proper-
ties dialog from the Setup menu (see “Field Properties” on page 330). (You can also open this dialog by dou-
ble clicking on the field name at the top of the column.)

The Field Properties dialog allows you to modify many of the attributes of each field. The New Database
Wizard has already set up some of the options in this dialog, including the Field Name and the Type.
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To set up the default value for this field press the Data Entry… button. The Data Entry options dialog has
several radio buttons for different default values — click the Today’s Date option.

After you click this option press this OK button twice to get back to the data sheet. Then press the Add New
Record tool (or select Add New Record from the Edit menu).

The new check automatically defaults to today’s date.
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Smart Dates

Panorama is very flexible about how you type dates. We call this feature “smart dates.” You can enter dates
numerically (for instance 04/09/02 or 4/9/2) or you can spell out the date (for instance April 9th, 1997 or Apr 9
97). You can use any character as a separator between numeric dates, for example 4-9-01 or even 4.9.01.

To enter today’s date, simply type today. You can also enter yesterday or tommorow. Panorama will auto-
matically convert these entries to the correct month, day and year.

If the date is in the current week, you can simply type in the name of the day, for example saturday or tue. To
specify a day in the previous or upcoming weeks add the words last or next, for example next tuesday or last
saturday.

Play around with entering different dates, then use the Cut Record tool to delete the new record.

Check Number

The second field contains the check number. You can modify the Field Properties to automatically add one to
create a new check number each time a new check is created. Click anywhere in the Check column and then
choose the Field Properties dialog from the Setup menu (see “Field Properties” on page 330). (You can also
open this dialog by double clicking on the field name at the top of the column.)

Type… Date Entered
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The New Database Wizard has already set up some of the options in this dialog, including the Field Name
and the Type.

To set up the default value for this field press the Data Entry… button. The Data Entry options dialog has
several radio buttons for different default values — click the Automatic increment by one option.
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After you click this option press this OK button twice to get back to the data sheet. Then press the Add New
Record tool (or select Add New Record from the Edit menu).

The new check automatically defaults to today’s date and is assigned the next check number, in this case 562.

Pay To

The third field contains the name of the person or company the check is made out to. Since you will often
write checks out to the same people over and over again you can take advantage of a very cool Panorama fea-
ture called Clairvoyance®. Clairvoyance automatically finishes your typing for you as soon as it thinks it can
identify what you are about to type based on the previous entries (see “Clairvoyance®” on page 387). Clair-
voyance can be turned on and off with the Field Properties dialog. Click anywhere in the Pay To column and
then choose the Field Properties dialog from the Setup menu (see “Field Properties” on page 330). (You may
have also heard that you can open this dialog by double clicking on the field name at the top of the column.
It’s really true!)
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The New Database Wizard has already set up some of the options in this dialog, including the Field Name
and Type and Auto Capitalize. Use the pop-up menu to turn on the Clairvoyance option, as shown below.

Press OK to close the dialog. Now try entering Blue Cross into the Pay To data cell. Leave your finger off the
Shift key as you type because Panorama will automatically capitalize the first letter of each word for you! As
soon as you press the letter l, Panorama’s Clairvoyance® feature will complete the entry for you by typing ue
Cross.

Clairvoyance automatically finishes your typing for you as soon as it thinks it can identify what you are
about to type based on the previous entries. If Clairvoyance guesses wrong (because this is a new entry that
hasn’t appeared before) just keep typing and complete the entry yourself.

B is automatically capitalized for you because of Auto Capitalize option

Clairvoyance automatically completes the entry for you
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Clairrows

When you hold down the Command key (Mac) or Control key (Windows), the up and down arrows on the
keyboard become clairvoyant arrows, or “clairrows.” With the key held down you can use the arrows to scan
through the values that are already in the database. Each time you press Command/Control-Down Arrow
the next value appears, while each time you press Command/Control-Up Arrow the previous value appears.
You can scan through the values until you find the information you are looking for, then press the Enter key
to enter the value. To give the clairrows a head start you can type in the first few letters of the information
you are looking for. 

Category

The Category field places each check into one of 11 categories (Rent, Insurance, Telecom, etc.) One way to
handle this field would be to use Clairvoyance® as described for the Pay To field. That way you would only
have to type in the first letter or two of the category. However instead of using Clairvoyance you are going to
set up a palette of radio buttons in the pop-up Input Box (see “The Choice Palette” on page 419). This palette
will have a radio button for each category. To set up this palette you’ll need to use the design sheet. Use the
View menu to switch from the data sheet to the design sheet.

type   b

l
Cmd/Ctl-Down Arrow

Cmd/Ctl-Down Arrow

Cmd/Ctl-Down Arrow

Cmd/Ctl-Up Arrow

Cmd/Ctl-Up Arrow

Enter
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The design sheet is kind of like a super-duper Field Properties dialog (see “The Design Sheet” on page 332).
It allows you to see and modify all the properties of every field at once. Each line in the design sheet corre-
sponds to a field, with the name and properties listed from left to right.

To set up the radio buttons click on the Category field name.

Now choose the Automatic Choices… command from the Special menu.

This command will build a list of the radio buttons from the existing data. If you leave the number at 2 the
command will include every category that occurs two or more times in the existing data (see “Creating the
List of Choices” on page 419).
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Press the OK button to create the list of choices. Since the width of the column is too narrow to see much of
the list you can either make the column wider or double click on the list to see the entire list (as shown
below). Notice that when a choice contains a space, for example Office Supplies, the space has been replaced
with an _ underscore character, i.e. Office_Supplies.

Use the View menu to switch back to the data sheet.

Before it switches back to the data sheet, Panorama will ask you if you want a “new generation” of your data-
base. What it is really asking you is to confirm the changes you just made to the design sheet (see “Database
“Generations”” on page 332). Press the Yes button.

Double click on the empty data cell at the bottom of the Category column. The Input Box will appear, but it is
so small you can only see the first button and part of the second.
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Move the mouse to the bottom right corner of the Input Box. The cursor will flip over (see “Expanding the
Input Box” on page 377). Drag the mouse to expand the Input Box.

The radio buttons will automatically flow into the expanded box as you change its shape.

The box can be tall and skinny, short and fat, or anything in between. To select a value just click on the button
and press Enter or Tab, or simply double click on the button. You can also select a value by typing in the first
few letters of the value, for example U for Utilities or Pu for Purchases.

The radio buttons are great if you want to select from one of the predefined categories, but what if you want
to add a check in a new category? To allow this you’ll need to go back to the design sheet (use the View
menu).

Double click on the list of choices, and then type a space and a dozen underscores at the end of the list. (The
underscore is just to the right of the 0 key, hold down the Shift key and press -).
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Press the Enter key and then use the View menu to go back to the data sheet. Double click on the Category
field.

It looks just the same as before! What’s up with that? To find out, expand the Input Box just a little bit more.

Now you can see that there is one additional radio button at the end of the list. To enter a new category click
on this radio button and then type in the new category, in this case Auto.

Press the Enter key when the entry is completed.

To learn more about this feature see “Exceptions” on page 420. Before going on to the next step I recommend
that you Save the database one more time.
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Looking Up the Category From a Previous Record

In this database a particular Pay To will almost always go with a particular category. For example the cate-
gory for checks to Blue Cross will always be Insurance, while the category for Staples will always be Office
Supplies. Panorama can be set up to automatically look up the category from the previous record, if any. To
do this you’ll use the design sheet again. Use the View menu to switch to the design sheet again, then double
click on the Equation column of the Category row (see “Automatic Calculations” on page 406).

Now choose lookup(…) from the Functions menu (see “Functions Menu” on page 1214).
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Choosing this menu item opens a dialog for setting up the lookup( function (see “Linking With Another
Database” on page 1289).

Start by selecting the database you want to look up data from, in this case the current database.

Next, tell Panorama that if there is more than one match in the database you are interested in the last match
(closest to the bottom), not the first (see “Lookup Variations” on page 1294).

Now tell Panorama what you want to look up, in this case the Category.
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We want to look up the category in the last record in the database where the Pay To value matches the Pay To
value in the current field. So select Pay To for both of the last two pop-ups.

Here’s the finished dialog with everything filled in.

Press the OK button to build the formula for looking up the previous category.

To learn more about how this formula works see “Linking With Another Database” on page 1289. For now
just press the Enter key and use the View menu to switch to the data sheet. Then start typing Staples into the
Category field.
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When you press the Enter key Panorama will automatically look up the appropriate category, in this case
Office Supplies.

Sometimes the check amount is the same from check to check also, for example a rent or subscription pay-
ment. You can go back to the design sheet and use the same technique to build a formula to look up the previ-
ous check amount. The formula is almost the same as before, but this time it looks up the Debit field and has
a default value of 0 instead of "" (see “Linking With Another Database” on page 1289).

One potential problem with both of these formulas is that they will stop working if the name of the check-
book file changes — it’s hard coded as My Checkbook. To fix that you can replace "My Checkbook" with
info("databasename"), as shown below (see “Looking Up Data in the Current File” on page 1300).

Press the Enter key, use the View menu to go back to the data sheet, then start typing Pacific Properties into
the Category field.
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When you press the Enter key Panorama will look up both the category and the amount from the previous
check to Pacific Properties.

If this isn’t the correct amount you can simply tab over to the Debit field and type in the actual amount. If you
haven’t done so already, Save the database again now.

Calculating the Checkbook Balance

To calculate the running checkbook balance you’ll need to record a quick procedure. Start by turning the
recorder on (see “Creating a Procedure with the Recorder” on page 1353).

Scroll over to the Balance field and click somewhere in the field.

Choose the Formula Fill… command from the Math menu (see “Filling a Field with a Formula” on page 511).
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Enter the formula Credit-Debit. You can use the Fields menu to help you type in the field names.

The finished formula should look like this.

When you press the OK button Panorama will perform this calculation over and over again for every record
in the database (see “Filling a Field with a Formula” on page 511).
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To complete the balance calculation choose the Running Total command from the Math menu (see “Running
Total” on page 464).

This command will calculate the balance after each check or deposit (see “Using Running Total to Balance a
Checkbook” on page 464).

To finish the recording select the recorder tool again.

Pick a name for the new procedure and type it in, then press the Create Procedure button.
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Now any time you need to update the checkbook balance you can simply select your new procedure from the
Action menu.

If you are curious to see what the code in your new procedure looks like you can use the View menu to open
it (see “Editing a Procedure” on page 100).

Before moving on to the next step it’s a good idea to… you guessed it, Save the database.

Drawing a Check Form

To complete your check database you’ll create a check form that can be used for data entry. If you are using a
Windows PC hold down the Alt key, if you are using a Macintosh hold down the Control key. Either way,
select New Form from the View menu (see “Creating a New Form” on page 545).

Type in the name of the new form (up to 25 characters).
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Press the Blank Form button to create the new form, then adjust the window to the approximate size of a
check.

Now choose the Form Preferences… command from the Setup menu and use the pop-up menu to set the
form’s background color to light green.
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Before you actually start building the form you need to customize the graphic tool palette. Use the Tool Pal-
ette command in the Setup menu to open the tool configuration dialog.

There are a total of 29 graphic tools available for use in Panorama (shown in the list below on the left). Many
computer screens are not large enough to handle this complete palette of tools (and we expect the number of
tools to increase in future versions). To get around this problem, Panorama allows you to customize the
graphic tool palette on the fly (see “Customizing the Tool Palette” on page 554). You can configure the palette
to contain only the tools that you need right now in any order you want. If your needs change later, you can
simply reconfigure the palette at any time.
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On the right is a list of the tools you currently have installed. If this list is empty, Panorama will use the
default tool palette. To move a tool from the left to the right, double click on the tool in the left. Or you can
select the tool (or tools) and press the Move or Insert button. Move the nine tools shown below into the list
on the right.

When you press the OK button the tool palette in the form will be updated.
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Creating the Text Editor SuperObjects

Using the Text menu or the Graphic Control Strip set the text size to 9 points (see “Text Font, Size and Style”
on page 643).

With the Pointer tool selected, click the mouse in approximately the location shown below.
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Now select the Auto Cell Layout command from the Arrange menu (see “Automatically Creating Rows or
Columns of Data Cells or Text Editor SuperObjects” on page 709). You used this command in your My Mail-
ing List database to create data cells, now you’ll use it to create Text Editor SuperObjects (see “Types of Data
Editing Objects” on page 682).

Start by holding down the Shift key and clicking on each of the first six fields.

Next click on the Create SuperObjects™ and 3D checkboxes.
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Press the OK button to create the Text Editor SuperObjects.

Text Editor SuperObjects may be used as an alternative to data cells for editing text within a form. You can
already see one difference between these two types of objects — the Text Editor SuperObject displays data
even in Graphic Design Mode, not the field name. To see the major difference between these two types of
objects switch the form to Data Access Mode (see “Form Modes: Data Access vs. Graphic Design” on
page 543).

Text Editor SuperObjects allow you to edit text right in the form window—no double click is required. You
can simply click or drag on the text to begin editing. Press Enter when you are finished. The illustration
below shows the effect of double clicking on the word Poly. As you can see, instead of opening an Input Box
this selects the word for editing.

Since the Text Editor SuperObject doesn’t use an Input Box, you cannot expand the size of the editing area
“on-the-fly” the same way you can with data cells. The editing area must be defined in advance. On the other
hand, the Text Editor SuperObject doesn’t require the extra double click, and works more like other standard
applications you may be used to. See “Creating and Modifying Text Editor SuperObjects” on page 689 to
learn more about Text Editor SuperObjects. For now, however, switch the form back to Graphic Design Mode
so that you can continue designing your new form.
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Dressing Up the Check Form

Select the Rectangle tool and draw a rectangle next to the check date (see “Creating a Graphic Object” on
page 552).

Change the Fill Pattern of the rectangle to solid black (see “Fill Pattern” on page 575).

Select the Text tool and create a click-text object that says Date. (see “Fixed Text Objects” on page 637).

Select the Pointer tool and then click on the new text object.
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Use the Graphic Control Strip to set the text color to light yellow (see “Color” on page 580).

Drag the text over the black box.

Adjust the black box and the text until they line up with the Text Editor SuperObject as shown below. To
adjust these objects you can drag them (see “Moving a Single Object” on page 564 and “Changing the Size of
a Single Object” on page 568) and nudge them with the arrow keys (see “Nudging an Object (or Objects)” on
page 565 and “Nudging the Size of an Object” on page 568).

Drag a marquee around these objects to select them (see “Selecting Multiple Objects at Once” on page 559).

Then drag the objects into the upper left hand corner of the form.
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Now drag a marquee just around the box and text objects.

Hold down the Shift and Option keys on the Mac, or Shift and Alt keys on the PC. With these two keys held
down drag the two objects to the right.

Holding down the Shift key insures that you drag the objects at 90 degrees, either perfectly up and down or
perfectly left and right (as in this case). Holding down the Option/Alt key tells Panorama to duplicate the
objects. When you release the mouse you’ll have two copies of these objects.

Select the Text tool and click on the new text object.

Edit the text to say Number instead of Date.

Select the Pointer tool and adjust the rectangle size to match the new text.
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Drag the check number up next to these objects.

Using the techniques you’ve just learned continue re-arranging the form until it looks like this.

Make a copy of the Pay To caption.

Change the text to Memo and expand the rectangle to about 1 inch high.
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Slide and resize the memo field itself into place.

To add a scroll bar to the memo field double click on the Text Editor SuperObject to open the object properties
dialog. This dialog lets you turn various object options on and off. Click on the Vertical Scroll Bar checkbox.

When you press the OK button the memo field gets a vertical scroll bar.
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To actually use the form you must switch into Data Access Mode. Notice that the background of the field
being edited turns white (in this case the memo field).

Use the Tab key to move from field to field.

Making the Form Elastic

An ordinary form is fixed — it stays the same no matter what the size of the window is. By adding a single
object to your form you can make it elastic. An elastic form adjusts automatically to fit the window — it
grows when the window grows and shrinks when the window shrinks. Start by switching back to Graphic
Design Mode. Then double click on the memo field to open the object properties dialog.
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Turn on the Grow Box option, then press the OK button. The memo field now reserves a spot for the win-
dow’s grow box.

Using the Rectangle tool draw a box in the spot reserved for the grow box.

Using the Duplicate command in the Edit menu, make a copy of the box (see “Duplicate” on page 612).

Set the Fill Pattern of the new box to solid black (see “Fill Pattern” on page 575).

Set the color of the new box to the same green color as the background (see “Color” on page 580).

Use the arrow keys to nudge the green box until it covers the white area but leaves the black border.

corner reserved
for grow box
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Now to make the form elastic. Start by selecting the Auto Grow tool. (If you can’t find the Auto Grow tool
you need to customize the tool palette. See “Customizing the Tool Palette” on page 554.)

Starting from the bottom right hand corner of the form, drag the mouse up and to the left. Release the mouse
somewhere between the left edge of the Category field and the right edge of the Pay To field, as shown in the
illustration below. (The blue and green lines in the illustration below have been added to highlight the loca-
tion of these edges.)

When you release the mouse the Auto Grow configuration dialog appears. The dialog is already filled out for
you except that you need to turn on the Draw Grow Icon checkbox.
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Press the OK button to finish creating this object.

The auto-grow object is covering up some of the memo field. To fix this use the Send To Back command in
the Arrange menu (see “Changing the Stacking Order” on page 620).

When you switch the form to Data Access Mode the auto-grow object completely disappears.

auto-grow object
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But the real fun starts when you adjust the size of the window. The form adjusts automatically to the new
size! See “Elastic Forms” on page 940 for a complete explanation of how this magic works.

To get rid of the extra scroll bars and tool palette choose the Window Tweak command from the Wizard
menu (see “Turning Window Components On and Off (Window Tweak Wizard)” on page 283).

In this case you may want to use the tool palette. To get it back uncheck the Tool Palette option in the Window
Tweak window.
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Then press the Tweak button twice. Here’s the final result.

Oh yeah, one more thing. You have been remembering to Save, right? Well, go for it now, and you’re done.
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Lesson 3: Building an Invoice Database
Invoice

Now that you’ve mastered basic skills in building databases, forms and procedures you’re ready to tackle a
more complicated task. Organizing invoices (or similar forms like statements, purchases, quotes, expense
reports etc.) is one of the most common jobs performed by database programs. Just as with the other two
databases you’ll start by launching Panorama and the New Database Wizard. On Windows systems you can
do this with the Start menu, on Macintosh systems you’ll use the Apple menu.

Instead of building this database from scratch you’re going to use the pre-built Invoice template in the Tem-
plate menu.
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When you select this template the wizard will call up a list of definitions for the twenty fields required for an
invoice, including default values and calculations.

By default the wizard will create a database that allows up to six line items per invoice. Let’s increase this to
twelve line items per invoice.

Press the Make New Database button to actually create the database. The new database has so many fields
that we can only see a small portion of them at once using the data sheet.

Before going any further you should Save the new database. Give it the name My Invoices and save it in the
same folder as your first two databases. Be sure to check the Save Window Positions option in the Save As
dialog.
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Line Item Fields

The New Database Wizard invoice template contained 20 fields. However, if you look in the design sheet (use
the View menu) you will see that the database actually contains 64 fields.

The solution to this is that four of the fields in the template, QtyΩ, ItemΩ, PriceΩ and AmountΩ, are actually
a special kind of field called line item fields. The wizard expanded each of these into 12 fields, Qty1, Qty2,
Qty2, etc., Item1, Item2, Item3, etc. This allows the invoice to contain information about up to 12 separate
items. It’s difficult to work with so many fields in the data sheet view, so you’ll create a form that allows you
to display and edit the data in a format that looks like a traditional paper invoice.
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Creating an Invoice Form

You already know how to create a new form, so make one named Order Entry. There’s no need to open it in a
separate window, you won’t be needing the data sheet again.

Using the techniques you’ve learned make the form look like the illustration below. If you need to review
these techniques see “Creating a Data Entry Form” on page 40 and “Drawing a Check Form” on page 140.
You may find it easier to switch the rulers to pixels instead of inches as shown in the illustration below, see
“Rulers” on page 563 to learn how to do this.

click text object

rectangle

data cell

all text is 9 point

pixels
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Adding Line Items to the Form

The heart of the order entry form is the line items. This section of the form will contain 56 objects — 48 data
cells (4 columns by 12 rows) plus 4 text objects and 4 rectangles for column captions. Fortunately the Auto
Cell Layout dialog will create most of these objects for you automatically. You’re going to create the line
items in the blank area to the right of the objects you’ve already created. Start making sure that black is the
currently selected color (see “Color” on page 580), then click the mouse in the upper left hand corner of this
blank area.

Now choose the Auto Cell Layout command from the Arrange menu. You’ve seen this dialog before. Since
we want to create line items press the Line Items button. This selects all of the line item fields.
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You don’t need to change any of the other options, just press the OK button. Panorama will automatically
create all 48 data cells you need in 12 rows by 4 columns.

You’ll need to make some adjustments to make the line items look right in your invoice. Start by choosing the
Spacing command in the Edit menu (see “Adjusting Spacing Between Multiple Objects” on page 608).

Click the Vertical option and type in 1 for the pixel spacing. Then press OK to adjust the vertical spacing
between the lines. There is now one pixel in between each line.
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Next you’ll want to adjust the width of the columns, starting with the Item column. To adjust the width,
move the mouse over the lower right hand handle of one of the objects in the column, then press and drag to
the right. Hold down the Shift key to make sure that you don’t change the height of the object, only the
width. If you hold down the S key (the letter S) you don’t have to exactly press on the handle itself, any-
where close to the bottom right hand corner of the object will do (see “Resizing Without Handles” on
page 571).

When you release the mouse all of the selected objects will adjust to the new width (see “Cluster Resize” on
page 593).
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Repeat as necessary until all the widths look the way you want. You can also nudge the widths with the
arrow keys for fine adjustments (after dragging the width, see “Nudging the Size of an Object” on page 568).

While holding down the Option key (Macintosh) or Alt key (PC) drag the small purple rectangle next to the
Date cell over the Qty1 text.

When you release the mouse there will be a new purple rectangle covering the text.

Adjust this rectangle so that it exactly covers the Qty1 text (see “Nudging the Size of an Object” on page 568).

While holding down the Shift key and the Option key (Mac) or Alt key (PC) drag this rectangle to the right
over the Item1 text.
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Adjust this new rectangle so that it covers the Item1 text.

Repeat for the Price and Amount columns.

While holding down the Shift key, click on each of the four purple rectangles you just created. This selects all
four objects (see “Selecting Multiple Objects at Once” on page 559).

Now choose the Send to Back command from the Arrange menu (see “Changing the Stacking Order” on
page 620).

Using this command moves the four purple rectangles behind the four text objects, making the text objects
visible again (see “Overlapping Objects” on page 619).

hold down SHIFT key and click on each object you want to select
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Because the text objects are black on a purple background they aren’t very easy to see. To change that, start by
clicking on an empty spot on the form. Clicking on an empty spot makes sure that the four purple rectangles
are no longer selected.

Now hold down the Shift key and click on each of the four text objects. With the four objects selected change
the color to light blue to match the other caption text (see “Color” on page 580).

The text will turn light blue, almost white.

click on any empty spot to make sure that no objects are selected

hold down SHIFT key and click on each object you want to select
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The annoying white border around the text objects is because these are auto-wrap text objects (see “Fixed
Text Objects” on page 637). The border will go away when you switch to Data Access Mode. However, we are
going to convert these objects from Auto Wrap text into Click text. To do this drag the lower right hand han-
dle of the object up over the upper right hand handle (see “Moving and Resizing Fixed Text Objects” on
page 640).

When you release the mouse the text is converted into click text, and the annoying border disappears.

Repeat this conversions for each of these four objects.

Now select the Text tool and edit the text to remove the 1 from the end of each object.

converted to click text
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Switch back to the Pointer tool and drag a marquee around all of the line item objects (see “Selecting Multiple
Objects at Once” on page 559). Because of the arrangement of objects in the form it is probably easiest to do
this from the bottom right to the upper left.

Now nudge the objects into alignment with the objects on the left hand side of the form (see “Nudging an
Object (or Objects)” on page 565).

Now you need to create the data cells for the subtotal, tax, shipping and grand total. Start by clicking on an
empty spot on the form (to make sure no objects are selected) and then drag a marquee around the Amount9
through Amount12 data cells.
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While holding down the Shift key and the Option key (Mac) or Alt key (PC) drag these four rectangles down
below the other line items (see “Drag Duplicating” on page 613).

Use the up arrow key to nudge the objects so that they are snuggled up with the Amount12 cell, then select
the Data Cell tool.

Move the mouse over the new Amount9 data cell you have created. The mouse arrow will turn into a tiny
menu icon (see “Working with Data Cell Objects” on page 685).
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Press the mouse and select SubTotal from the pop-up menu.

When you release the mouse the data cell will be assigned to the SubTotal field.

Repeat this for each of the other three data cells.
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Since you’re pretty much a professional by now you should have no problem finishing up this form so that it
looks like this.

Be sure to Save this masterpiece before you go any further.

Entering Data into the Invoice

Before you can enter data into the invoice you must switch to Data Access Mode. You may also want to adjust
the size of the window to match the size of your form.

As you start typing data you’ll quickly discover a problem. Pressing the Tab key after you enter the name
causes Panorama to tab into the first Qty line item instead of the Company field. Oops!
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To fix this problem switch back into Graphic Design Mode. While holding down the Shift key click on the
Name, Company, Address, City, State, Zip, Country, Phone and Memo data cells 

Now select the Group command from the Arrange menu.

This command combines the nine objects into one combined object (see “Grouping Objects Together” on
page 588). Instead of having handles around each individual object (see illustration above) there are now
only four handles around the four corners of the combined object.

handles for group object
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Now each time you press the Tab key Panorama will advance to the next cell within the group (see “Tab
Order in Forms” on page 717).

The next tab will bring you to the first line item field. Enter the quantity, item and price.

When you press the Enter key Panorama will calculate the line item total, subtotal, tax and grand total.

These calculations were set up for you by the New Database Wizard. To learn how to set up or modify these
calculations yourself see “Automatic Calculations” on page 406.
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Lesson 4: Building a Price List

Now that the invoice is complete you will build a price list database and link the price list to the invoice. Start
by launching Panorama and the New Database Wizard. The price list database will have two fields — Item
and Price. (See “Fields” on page 327 for a complete explanation of fields.) Type in the name of each field into
the wizard, with each name on a separate line. The Price field will contain money values so it should have a
suffix of $.

When you press the Make New Database button the wizard will create a new database for you. The database
is displayed using a row and column format called the data sheet. The new database contains one blank
record (line) and two fields (columns). 

Loading the Data

To use the price list you’ll need to type in a bunch of data. That still doesn’t sound like much fun, so we’ve
created a database that is programmed to automatically fill your new price list database with sample data.
Start by choosing Favorite Databases from the Wizard menu (see “The Favorite Databases Wizard” on
page 191).



Page 176 Panorama Handbook
The database you need is called Sample Price List. To locate it, choose Search… from the Group menu (see
“Searching for a File” on page 199). You can also press Command-F (Macintosh) or Control-F (Windows).

Type in some or all of the name Sample Price List.

The wizard will show you a short list of files including the one we want.

Double click on the Sample Price List file to open it. A small window will appear briefly. The database has
been pre-programmed to automatically transfer the price list data into the new database you have created.
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You may want to adjust the font size and the widths of some of the columns (see “Adjusting Column Widths,
Font and Size” on page 13).

Before continuing you should use the Save command in the File menu to save your new creation. The first
time you save any file Panorama will ask you to give it a name. You’ll also want to check the Save Window
Positions option (see “Saving Window Positions” on page 213). When everything is set up press the Save but-
ton. (To see what this dialog looks like on the PC see “Saving Your Work” on page 7.)

You may also want to add your new file to the Favorite Database wizard. See “Adding A Database To Your
List Of Favorites” on page 26 for a refresher on how to do this.

select folder you want to save file in

type in name of file

tell Panorama to save window positions
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Linking the Price List to the Invoice

The price list is now ready to link to the invoice. The link will be designed to look up a price automatically
when an item is entered into the invoice. Start arranging the invoice and price list windows so that both are
visible, with the invoice window on top (something like the illustration shown below). 

Using the View menu, switch from the invoice form to the invoice design sheet (see “The Design Sheet” on
page 332).
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Double click on the Equation cell in the Price1 row.

Now choose lookup(…) from the Functions menu (see “Functions Menu” on page 1214).



Page 180 Panorama Handbook
Choosing this menu item opens a dialog for setting up the lookup( function (see “Linking With Another
Database” on page 1289).

Start by selecting the database you want to look up data from, in this case the My Price List database.

Now tell Panorama what you want to look up, in this case the Price.

We want to look up the price where the Item in the price list matches the Item value in the invoice. So select
Item from My Price List.
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Select Item1 for the last pop-up.

Here’s the finished dialog with everything filled in.
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Press the OK button to build the formula for looking up the price.

To learn more about how this formula works see “Linking With Another Database” on page 1289. The for-
mula generated by the dialog needs one slight adjustment — Item1 must be replaced by Item‰. To type the
‰ character use Option-Z on the Macintosh and Alt-0166 on the PC (see “Special Characters” on page 1225
and “Line Item Fields” on page 1220).

Once this adjustment has been made press the Enter key. Panorama will respond with this dialog (see “Mod-
ifying Line Item Fields” on page 345).



Page 183
Press the Yes, and don’t ask me again button. Panorama will update not only the Price1 field definition, but
also Price2, Price3, Price4 etc. You can see this by scrolling down the design sheet. (We’ve split the window
into two panes (see “Splitting a Window” on page 278) and expanded the width of the Equation column to
make this easier to see.)

Now click on the Item1 field name (we’ve also unsplit the window and reduced the width of the Equation
column).

Choose the Set Up Link command from the Special menu (see “Clairvoyance® Across Multiple Files” on
page 389).

On the left hand side select My Price List. Then select Item on the right hand side (as shown above).
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Press OK to set up the link.

The link must be copied to all of the other item fields (Item2, Item3, Item4, etc.) To do this, double click on the
link.

When you press the Enter key the link specification will be copied to all of the other Item fields.

Use the View menu to switch back to the Order Entry form. When Panorama asks you if you want to create a
new generation, press the Yes button (see “Database “Generations”” on page 332). Then Save the database
before continuing.
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Using the Linked Invoice & Price List

Since you’ve set up a Clairvoyant link between the invoice and the price list you’ll only need to enter the first
few letters of a description.

When you press the Enter key Panorama will look up the price from the Price List database. Once the price is
looked up Panorama will then automatically calculate the subtotal, tax and grand total.

You can enter up to 12 items in each invoice.
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Creating a Procedure to Add an Item

Now you’ll write a very short procedure. Start by clicking on the Price List database.

Use the View menu to create a new procedure named Add Item to Invoice (see “Writing a Procedure from
Scratch” on page 1357). Type in the four lines shown below, exactly as they are shown. (Remember, the Ω
character is typed in by pressing Option-Z on the Macintosh or Alt-0166 on the PC. Depending on the fonts
installed on your system the character may not look like Ω, but it will work if you press the right keys.)

To check your typing use the Check Procedure tool. This tool can spot most typing mistakes (see “Checking
for Mistakes” on page 1362).
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Assuming there are no errors use the View menu to switch back to the data sheet. (If there are any errors - fix
them!) Then pick the item you want to add to the invoice and choose Add Item to Invoice from the Action
menu.

The procedure will automatically add the selected item to the invoice.

To learn more about how this procedure actually works see “Assignment Statements” on page 1367, “Win-
dows” on page 1544 and “Moving Left and Right” on page 1591.

Creating a Price List Form with Buttons

Now you’ll create a price list form with buttons for adding items to the invoice. Start by using the View menu
to create a new form named Add.
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You’re going to make a View-As-List form (see “View-As-List Forms” on page 917). To do this start by select-
ing the Tile tool. You may need to scroll the tool palette to access this tool (see “Scrolling the Tool Palette” on
page 277).

Expand the width of the window slightly, then drag the mouse across the form to create a tile (see “Working
with Tiles” on page 926).

When you release the mouse a new data tile appears.
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Before you continue with the next step you’ll need to customize the tool palette. To do this choose Tool Pal-
ette from the Setup menu and then arrange the tools as shown below (see “Customizing the Tool Palette” on
page 554).

Press the OK button, then select the Push Button tool (see “Push Buttons” on page 853).

Now drag to create a button in the upper left hand corner of the data tile.
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Now you’ll need to select three options for the new push button. Using the pop-up menu select the procedure
linked to this button, in this case Add Item to Invoice. (This means that when this button is pressed the Add
Item to Invoice procedure will be triggered, just as if you had selected it from the Action menu.) Type in the
title you want to appear in the button, in this case Add. Click on the button style you want to use, in this case
3D Rounded Rectangle.

When you press the OK button the new push button will appear on your form.

Select the Pointer tool and adjust the text size and overall dimensions of the button (see “Text Size” on
page 583).
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Now select the Text Editor tool (see “Text Editor SuperObject” on page 689).

Drag the mouse to create a text editor object.

When you release the mouse the Text Editor SuperObject configuration dialog appears (see “Text Editor
Options” on page 692). Set the options as shown in the illustration below.

When you press the OK button the new Text Editor SuperObject will appear.
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Select the Pointer tool and adjust the size and position of the new object (see “Nudging the Size of an Object”
on page 568).

Hold down the Option key (Mac) or the Alt key (PC) and drag the Text Editor object to the right (see “Drag
Duplicating” on page 613).

Adjust the size of the new object and select the Right command from the Text menu (see “Text Alignment” on
page 644).

Double click on the new text editor object (see “The Object Properties Dialog” on page 586) and change the
field to Price.

Press OK to update the object.
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Click in the tiles’ drag bar to select it (see “Working with Tiles” on page 926).

Use the color menu to change the tile to light gray.

Drag the lower left hand handle of the tile up until there is an equal margin around the button and text editor
objects.

The finished form should look something like this.
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Using the Form Preferences dialog in the Setup menu, change the viewing format for the form to View-As-
List.

Press the OK button, then switch back to Data Access Mode.

Here’s what the form should now look like in Data Access Mode. The graphics on the tile are repeated over
and over again for each record in the database.
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To add a particular item to the current invoice just click on the Add button for that item.

Clicking this button will trigger the procedure which adds the item to the invoice.

Now Save both databases and you are done.
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Saving a File Set

Before continuing, make sure that the My Invoice and My Price List files are the only two databases open in
Panorama. Then choose the File Save command from the File menu. Type in the name of the file set you want
to create (in this case Order Entry) and click on the Set option.

If you are using a Windows PC computer use the combo box to choose the Panorama File Set {*.pnz} option
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Press the Save button to create the file set document.

Later if you want to open both the My Invoices and My Price List files together you don’t need to open them
separately. Instead you can simply double click on the Order Entry icon, and Panorama will open both files
automatically. See “File Sets” on page 217 to learn more.
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