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Step-by-Step Tutorials

It’s time to jump into the database fast lane! By the time you finish the lessons in this tutorial you’ll have a
solid foundation in the basic techniques you’ll need to use Panorama effectively.

This tutorial is divided into four lessons. Each lesson builds on the previous lessons and introduces more
advanced topics. In “Lesson 1: Building Your First Mailing List Database” on page 4 you’ll learn how to cre-
ate and set up a simple mailing list database. In “Lesson 2: Building and Organizing a Checkbook” on
page 105 you’ll not only build a simple checkbook register file but also learn several techniques for organiz-
ing and summarizing the checkbook data. In “Lesson 3: Building an Invoice Database” on page 186 you’ll
create a simple invoice for creating and tracking orders. Finally, in “Lesson 4: Building a Price List” on
page 205 you’ll create a price list and link it to the invoice database. Each lesson should take from 30 minutes
to an hour to complete. The lessons are designed so you can easily follow along and actually build each data-
base as you read. There are plenty of illustrations to show what the screen will look like at each step, so you
don't need to worry about getting lost. 

Before you begin, you’ll need to install Panorama on your computer. If you haven’t done so already, see
“Installing the Software” on page 13 of Welcome to Panorama. It’s not necessary to activate Panorama to com-
plete the operations in this tutorial. If you haven’t purchased Panorama yet you can try out the tutorials
before you decide that you want to purchase Panorama.

I hear the bell—class is about to begin. It’s time to get started with your new Panorama career! I hope you
have as much fun learning Panorama as we had creating it for you.

Sincerely,
  

Jim Rea, President

P.S. This tutorial teaches you how to work with Panorama. It assumes, however, you already are familiar
with your computer and operating system. You should be able to point, click, and drag selections, and be able
to make selections from menus, use scroll bars, and edit text. If you are not familiar with these skills, you
should review the tutorial information supplied with your computer.
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Lesson 1: Building Your First Mailing List Database
Mailing List

A mailing list for storing names and addresses is one of the most basic database applications, and is very sim-
ple to create with Panorama. Double click the Panorama application to start (or, if you are using Microsoft
Windows, use the Start menu. Panorama will automatically open the New Database Wizard, shown below.
(If you are already in Panorama you can open this wizard by choosing New File from the File menu.)

To create a database start by typing in the name of the first field. You can also click on the yellow star to
choose from a list of common field names.

Type here, or...

choose here
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To add a second field, press the + button and fill in the field name, like this:

There’s a shortcut if you’re creating a field with a common name — right click on the + button (or Control-
Click), then choose the field name from the pop-up menu.

For this lesson you will create a new mailing list database with seven fields — First, Last, Address, City, State,
Zip and Phone. (See “Fields” on page 193 of the Panorama Handbook for a complete explanation of fields.) The
wizard has a favorite for a database that has almost exactly these fields, to use this simply click on the yellow
star and choose Mailing List.

The fields for a mailing list are automatically filled in for you.
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This template isn’t quite what we wanted for our new database — we don’t need a Country field but we do
need a Phone field. To fix this simply click on and edit the field name, or click on the yellow star and choose
Phone from the pop-up menu.

At this point you could add more fields, or edit or re-arrange the existing fields, but for this example we are
done and ready to create the new database. To do this simply press the Make New Database button at the
bottom of the window.

click here to edit 
field name ...

or choose name from pop-up menu
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When you press the Make New Database tool the wizard will create a new database for you. The database is
displayed using a row and column format called the data sheet. The new database contains one blank record
(line) and seven fields (columns).

Entering Data Into Your New Database

The new database is ready to use immediately — you can just start typing to enter data. For example, to enter
the name Bob simply start by pressing the b key. A small pop-up window will appear over the current cell.
This pop-up window is called the Input Box and is used for all data entry in the data sheet (see “The Input
Box” on page 272 of the Panorama Handbook).

Complete the entry of the name by pressing ob. Notice that Panorama automatically capitalized the first
letter of the name. We’ll show you how to turn this feature on and off later (see “Automatic Capitalization”
on page 281 of the Panorama Handbook if you can’t wait).
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When you’ve finished with the first name press the Tab key to move on to the last name.

Continue typing and pressing the Tab key until you get to the phone number. When you tab into the Phone
field you’ll notice that Panorama automatically types in the ( for you.

The New Database Wizard has set up an Input Pattern to make typing the phone number easier (see “Input
Patterns” on page 291 of the Panorama Handbook for more information). All you have to type is the numbers,
for example 7024879023. Panorama will type in the punctuation for you.

Once you’ve finished entering the phone number you have a choice to make. Press the Tab key if you want to
add another line and continue editing data.

Press Return or Enter if you are done with data entry for the moment.

Panorama types in (, ), space and - for you
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Making Corrections

It’s easy to change the contents of any cell. Start by double clicking on the cell. This opens the Input Box,
allowing you to type in a new value or to make corrections.

Press the Enter key or click on another cell when you are finished. (You can also press the Tab key if you want
to skip to next cell and edit it too.)

Editing a Multi-Line Cell

If you need more room to enter your data, you can expand the size of the Input Box. For example, you might
need to expand the Input Box to enter an address with more than one line. To expand the Input Box, move the
arrow to the lower right hand corner of the box. When the mouse reaches the corner, the arrow will flip over
so that it is pointed down instead of up.

When you see the arrow flip over, press the mouse and drag the corner of the box to the size you want.

double click to edit cell

mouse “flips over” in lower right hand corner
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When you release the mouse the Input Box will expand to the new size.

Now that the Input Box has been expanded you can use the Return key to add additional lines to the data
cell. You can add as many lines as you like.

When you are finished editing the address press the Enter key. The Input Box closes and now you can only
see the first line of the data. (If you want to see more than one line of data in a cell that is not being edited you
must use a form, see “Displaying and Editing Text” on page 587 of the Panorama Handbook).

If you double click to edit the data cell again Panorama will remember the new size of the Input Box.

only first line of text is visible in data sheet
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You can adjust the size of the Input Box any time it is open.

If the Input Box is less than one inch high it won’t have a scroll bar.

To learn more about expanding the Input Box see “Expanding the Input Box” on page 273 of the Panorama
Handbook.
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Saving Your Work

To permanently store your new database choose the Save command from the File menu. Using the dialog,
choose the folder you want to save the database in. Type in the name of the file and check the Save Window
Positions option if it is not already checked. When everything is set up press the Save button.

select folder you want to save file intype in name of file

tell Panorama to save window positions
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If you are using a Windows PC the dialog looks a little bit different but the procedure is exactly the same.

After the file is saved the name of the window will change from Untitled to the name of the file, in this case
My Mailing List.

Type in name of file

select folder you want to save file in

tell Panorama to save window positions
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Importing Data Into the Mailing List

If you already have data in another program (FileMaker, Access, Excel, etc.) you can transfer that data to Pan-
orama by exporting it into a text file (tab or comma delimited) and then importing it into Panorama. Pan-
orama includes some text files with sample data, so we’ll import one of those files now. Start by choosing
Import Text from the File menu.

name of database data will be imported into

fields in database
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The next step is to select the text file that contains the data to be imported and drag it onto the wizard. For
this tutorial we’ve prepared sample data that is ready to use. To see this file, choose Show Sample Text Files
from the Special menu.

Now drag the file 200 Sample People.txt from the sample text folder onto the Text Import Wizard window.
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Now the wizard will show the data contained in text file. In this case the imported text has 15 fields, of which
six are currently visible.

Use the Tab Width pop-up menu to make the imported columns wider or narrower.
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The next step is to assign data from the imported text to specific fields in the mailing list database. Start by
dragging the second column of imported data into the First field.

Then drag the fourth column into the Last field.
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Continue to drag each of the text fields you want to import onto the corresponding database fields.

Once all of the fields are set up press the Import button.
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The wizard will import the data from the text file into the database.

Your database now contains 201 records — the single record you typed in plus the 200 records imported by
the Text Import Wizard. The total number of records is displayed in the lower left hand corner of the window.

Before you go any further you should use the Save command (in the File menu) to save the new data in the
database. Since you have already saved this file once and given it a name, Panorama will quickly save the file
without asking you for the name and location again.

To learn more about the Text Import Wizard see “Using the Text Import Wizard” on page 94 of the Panorama
Handbook.

Adjusting Column Widths, Font, Size and Background Color

To adjust the width of a column in the data sheet, move the mouse over the right half of the column name
(left half if the column is numeric or right justified). When the mouse is over the right half of the name it will
turn into a double left/right arrow.

total number of records in the entire database

mouse turns into double left/right arrow
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To adjust the column width press and drag to the left or right.

When you release the mouse the column width will be adjusted.

You can use this technique to adjust the widths of as many columns as you like (see “Changing the Width of
a Field” on page 199 of the Panorama Handbook for more information on changing field widths).



 

Page 21

       
Use the Font dialog in the Special menu to change the font and size of the text displayed in the data sheet.

When you change the size of the text Panorama changes with width of each column proportionally, so that
you do not need to adjust the widths of the columns.

Use the Save command (File menu) to save the new configuration.
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To change the background color of the data choose Preferences from the Panorama menu, then click on Gen-
eral Preferences. Then click the Data Record option of the Background colors section.

Use the dialog to choose the background color you want.

click here to change background color
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When you press Ok all open data sheets will change to the color you selected.

The new color will be used permanently for all data sheets until you change it. (For the remainder of this
tutorial this book uses the default gray background color.)

Sorting the Database

Now that the database is filled with sample data you can try out Panorama’s commands for organizing data.
To sort by zip code start by clicking anywhere in the Zip column.

Now choose Sort Up from the Records>Sort menu.

click anywhere in this column
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Panorama will sort the database as soon as you release the mouse. Notice that the zip code you originally
clicked on is still highlighted. If you want to see the first zip code you’ll need to use the vertical scroll bar to
move to the top of the database.

Note: An alternate way to sort is to right-click on the field name and choose Sort Up from the pop-up menu.

If you don’t have a two button mouse you can hold down the Control key and click on the field name.
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Sorting By Two or More Fields

You can sort by as many fields as you like. In this example you will sort by cities within states. The first step
is to sort by states. To do this click anywhere in the State field and choose Sort Up from the Records>Sort
menu.

Now the database is sorted by state, but the cities within each state are still out of order. For example, Hialeah
should be the first state within Florida (FL) and Atlanta should be the first city within Georgia (GA).

click anywhere in State field… then Sort Up
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To sort the cities within the states first click anywhere in the City field, then choose Sort Up Within from the
Sort menu. Be sure to choose Sort Up Within, not Sort Up.

The database is still sorted by state, but now the cities are sorted within each state as well.

You can use Sort Up Within as many times as you wish in your database. For example, you could now sort
the last names within each city. To learn more about sorting see “Sorting” on page 323 of the Panorama Hand-
book.

click anywhere in the City field… then Sort Up Within
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Finding a Person

It’s easy to search for anything in a Panorama database — just choose Find/Select from the Records>Search
menu.

Type some or all of the text you wish to find into the dialog. In this case we what to search for a person named
Gutierriz so we will enter the first few letters of the name. As each key is pressed Panorama instantly shows
the data that matches your search (by default Panorama searches all fields in the database, we’ll show you
how to customize that in a moment).

When you press the Find button Panorama will locate Ms. Gutierrez.

(2) press Find button(1) enter some or all of name you want to find
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Finding Multiple People

Suppose you want to look up someone who’s first name is Alan, but you’re not sure what the last name is.
Start by choosing the Find/Select command. Clear out the previous search, then type in alan. The dialog
instantly updates to show that there are five people named Alan in this database.

When you press the Find button Panorama will find the first person named Alan in the database.

If this isn’t the Alan you were looking for choose Find Next from the Records>Search menu. Panorama will
skip to the next Alan in the database.

You can continue using the Find Next command until you have located every Alan in the database, and you
can use Find Previous to skip backwards.

click here to clear previous search
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You can also use the Find/Select dialog to jump directly to any of these five people. Start by re-opening the
Find/Select dialog, then simply double click on any row in the search results to jump directly to the corre-
sponding record.

After jumping to a specific record you can use Find Next skip forward and Find Previous to skip backwards
from that point if you wish.

double click to jump directly to a specific record
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Selecting Instead Of Finding

A second way to locate every person named Alan is to select the information (see “Finding vs. Selecting” on
page 331 of the Panorama Handbook for an extended discussion of this topic). To do this re-open the Find/
Select command, but press the Select button instead of the Find button.

Most of the database will disappear. In fact, only the records containing alan will remain visible (selected).
Everything else is temporarily invisible. Panorama displays the number of selected records in the lower left
hand corner of the window. In this case five records contain alan. We say that these five records are the
selected records. The other 196 records are invisible (unselected).

five selected records contain the name Alan
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Selecting from a Specific Field

So far we’ve been searching thru all fields in the database. In some cases, however, that doesn’t work out so
well. For example, suppose you want to locate all addresses in the state of California. Searching all fields for
ca brings up dozens of “false positive” matches like cambridge, carl, and american (if you scroll down you’ll
see that the California records we are looking for are included also).

To get rid of the false positives, use the pop-up menu to change Any field contains to State (the field we want
to search).
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Not type in ca. This time, only records from California are shown, with no false positives.

At this point you can press the Select button to select the California records in the data sheet, you can press
the Find button to locate the first record in the California, or you can double click on any of these records to
jump directly to it.

Selecting More of the Same

If you see something in your database and want to see more items that are similar, just right-click on the data
and choose Select Same from the pop-up menu. For example if I see a person named Sandra and want to see
if there are any more, I right click on the name and choose Select Same.
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It turns out there are four Sandras in this database.

You can repeat this process over and over, for example to select all records in Ohio.

Here is the selection.

If a database contains dates the pop-up menu allows you to select a range of similar dates — either a day, a
week, a month, a quarter or a years (see “Selecting with the Context Menu” on page 333 of the Panorama
Handbook).
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Using the Sounds Like Option

If you don’t know exactly how something is spelled you can try using Panorama’s sounds like option. To use
this option open the Find/Select dialog, choose the field to search, then choose the Sounds Like option.

Since the name Allen “sounds like” Alan, it now shows up in the search.

The sounds like option isn’t perfect, but it can find most similar sounds and spellings. You must, however,
know the first letter of the word or name you are looking for. For example, the sounds like option will never
think that the name Ellen sounds like Alan because the two names start with different letters.

1) choose field to search

2) choose sounds like option

3) type text to search for
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Making More Complex Selections

The Find/Select dialog can make more complex selections based on multiple criteria. For example, suppose
you want to select all people with zip codes from 50000 to 69999. This search can quickly be set up with the
pop-up menus.

Now suppose that in addition to records in this zip code range, you would also like to select all records in
Connecticut. To do this, start by changing the pop-up menu from All of the following are true to Any of the
following are true.

Next, press the + button to add another row to the search criteria.

1) choose field to search 2) choose type of search 2) enter text to search for

click here

to add another search criteria row
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Now fill in this new row to select Connecticut in addition to the original zip code range.

The process can be repeated to add up to eight search criteria rows.

As was described before, at any point you can press the Select button to select the specified records, or press
Find to jump to the first specified record, or double click on any record in the Find/Select dialog to jump to it.
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Selecting Data Based on a Formula

The Find/Select dialog pop-up menus can be used to set up a wide variety of specific search criteria. How-
ever, if you can’t find the search you want in the menus you can also use any boolean (true/false) formula.
This also allows you to use parentheses to control exactly how search comparisons are combined. To perform
a formula search, start by changing the pop-up menu from Any field contains to Formula is true.

Now type in a true/false formula. The formula shown below selects everyone on the west coast (California,
Oregon or Washington) with a phone number in the database.

To learn more about selecting with a formula see “Search Options (Formula)” on page 351 of the Panorama
Handbook and “True/False Formulas” on page 124 of Formulas & Programming.
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Selecting All Records

To make all of the invisible data re-appear choose Select All from the Search menu.

Panorama will display all of the data in the database again.
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Saving Your Favorite Searches

If you need to do the same or similar searches over and over, you can save any search so that you can re-use it
later. The first step is to set up the search — for example this search selects all states along the Pacific coast of
the United States.

To save this search, click on the yellow favorites icon and choose Add to favorites. 

Enter the name for your new favorite search.
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Now the new favorite is included in the menu, so you can re-use it at any time.

For more information about favorite searches see “Managing Queries” on page 355 of the Panorama Handbook.

Closing a Database

To close a database first click on it (to bring its window to the front). If the database has only one window you
can close it by clicking on the window’s close box. If the database has more than one window you can close
each window individually or you can select the Close File command from the File menu. Close the My Mail-
ing List database now.

If the database has been modified since the last time it was saved Panorama will ask you if you want to save
the changes. Press the Save button to save the changes.

The database is now closed, and the memory it was using is available for use with other databases. See “Mon-
itoring Memory Usage” on page 137 of the Panorama Handbook to learn how to oversee Panorama’s memory
usage.
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Re-Opening a Recently Opened Database

You can always open any database by double clicking on it in the Finder (Mac) or Windows Explorer (Win-
dows).

If the database was recently opened or saved by Panorama, you can also quickly open it by choosing Recent
Databases from the File menu. A list of recently accessed databases appears.

Since My Mailing List was the last file I accessed, it’s at the top of the list. I can double click on that row to
open it, or I can simply press the 1 key (numeric 1). In fact, any of the nine most recently accessed databases
can be opened simply by pressing the corresponding digit (for example pressing 4 will open the Tickler
file).

The Recent Databases window can display hundreds of recently accessed files. If the file you are looking for
isn’t immediately visible you can type a few letters search for it. The example below shows all recently
accessed data relating to purchases.

To learn more about this wizard see “The Recent Databases Wizard” on page 44 of the Panorama Handbook.

double click to open
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Printing the Data Sheet

Before actually printing the data sheet you’ll set up a page header to print today’s date on the top left and the
page number on the top right of each page. To do this choose Headers/Footers from the File menu. This com-
mand opens a dialog that allows you designate headers on the top left, center and right and a bottom cen-
tered footer.

Start with the top left header. Type in the words Printed on and then press the Month dd, YYYY button.

type Printed on

then press button
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Now for the top right header. Type Page and then press the Page#  button.

Once both headers are set up press the OK button. (To learn more about the header and footer options avail-
able when printing the data sheet see “Printing Data Sheet Headers & Footers” on page 1048 of the Panorama
Handbook. When printing a form you have complete control over the exact layout of headers and footers —
see “Custom Reports” on page 1061.)

Next, choose the Page Setup command from the File menu. (Before you do this, make sure that the printer
you want to use is connected to your computer and selected.) The exact options available in the Page Setup
dialog depend on the operating system and what kind of printer you are using, but in general you can control
the page size, orientation (tall or wide), and print reduction factor. Here is a typical Page Setup dialog.

type Page

then press button
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Select the printing options you want to use and press the OK button. To actually print the data sheet choose
Print from the File menu. The printing dialog will appear. The exact options available in this dialog depend
on the operating system and what kind of printer you are using, but in general you can control which pages
to print, how many copies to print, and whether you want to manually feed the paper. Here is a typical Print
dialog.

For the exact details on the operation of this dialog see the documentation that came with your printer. Press
the Print button to print the data sheet. Panorama will automatically print as many sheets as necessary.

If you want to print only a portion of the database, use the Select button in the Find/Select dialog to select
the data you want before printing the database (see “Selecting Instead Of Finding” on page 30). Only the vis-
ible records will be printed.
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Temporarily Hiding One or More Fields

If you need to temporarily hide a field, simply click anywhere in the field and then choose Hide Field from
the Fields menu. (Alternately, you can right click on the field name and choose Hide Field from the pop-up
context menu.

The field, in this case Phone, disappears. You can hide as many fields as you want as long as at least one is
visible.
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To make all hidden fields visible again, choose Show All Fields from the Fields menu. Or you can choose
Hide/Show Fields from the Fields menu. This opens a dialog that allows you to choose which fields to show
and which to hide.

When you press Apply, only the checked fields will be shown.

This technique is especially useful when you want to print only certain fields. Simply pick the fields you
want and then choose the Print command. If there is a certain set of fields you use over and over again you
can set up a favorite for them. Start by opening the Hide/Show Fields dialog and pick the fields you want to
show. Then click on the yellow star and choose Add to Favorites.
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Type in a name for your new favorite.

Now you can quickly call up this field configuration at any time simply by clicking on the yellow star.

Automating Tasks with Procedures

Right out of the box, Panorama is a very flexible program. Its built in menus and tools bring incredible power
to your fingertips. Even better, you can easily create your own commands that can be activated with a menu
or button. You can create these commands (called procedures) using Panorama’s built in programming lan-
guage or simply by recording each step with the built in recorder. To start recording a procedure just click on
the Record Procedure tool. The wheels of the recorder will start to spin to let you know that Panorama is
recording your actions (the recorder is described in detail in “Creating a Procedure with the Recorder” on
page 212 of Formulas & Programming).

I’ll use the recorder to create a procedure that sorts the database by first and last names. With the recorder
running (make sure the reels are spinning) I perform the following steps (using the sorting technique you
learned earlier, see “Sorting By Two or More Fields” on page 25).

Step Action

1 Click on the Last field.

2 Choose Sort Up from the Records>Sort menu.

3 Click on the First field.

4 Choose Sort Up Within from the Records>Sort menu.
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When you’ve finished with these steps press the Record Procedure tool again. This stops the recording.

After you stop the recorder a dialog box will appear. Type in the name of the new procedure (in this case Sort)
and press the Save Procedure button.

Next I’ll create a more complicated procedure to print the addresses in zip code order. I start by turning the
recorder back on again.

With the recorder running perform the following steps.

Step Action

1 Click on the Zip field.

2 Choose Sort Up from the Sort menu.

3 Choose Hide/Show Fields from the Fields menu.

4 Uncheck the Phone field, leaving the others checked.

5 Click on the Apply button.

6 Choose Print from the File menu

7 Click on the Print button
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When I’ve finished with these steps I press the Record Procedure tool again to stop the recording.

Again, Panorama asks me to give this procedure a name of its own.

Before I go any further I will Save the database with the new procedures I just created.

Using the Action Menu

If you look closely, you’ll see that a new menu has appeared — the Action menu. This menu contains the two
procedures that were just recorded.

When you choose a command from this menu it replays the steps that were recorded in the procedure. If I
choose the Sort Names command, Panorama replays the recorded steps as fast as it can — zip zip zip.

To learn more about the Action menu see “The Action Menu” on page 355 of Formulas & Programming.
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Editing a Procedure

A procedure can be opened to see what’s inside. To see what is inside a procedure, right click on the View
menu and choose the procedure name (if you have a one button mouse, hold down the Control key).

A new window opens, showing the steps of the procedure. Each step you recorded appears in a simple
English-like format.

With this window opened you can edit the steps that were recorded. For example, if you made a mistake dur-
ing the recording, you could fix it now. You can also add new steps by typing them in (or cutting and pasting
from another recording). For example, if I add the step firstrecord to the end of this procedure, Panorama
will automatically jump to the beginning of the database after sorting the data. To try this out I can either
click on the data sheet and use the Action menu, or I can simply press the Run tool.

right click or hold down control key to open procedure 
in a separate window
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Panorama has hundreds of commands — how did I know that firstrecord was the one I needed to jump
to the top of the database? To help find the command I need I use the Programming Assistant dialog, in the
Edit menu. Once this dialog I can search for the command I am looking for. Aha ... there it is, firstrecord. Now
I can simply double click on it to insert it into the procedure (to learn more about this assistant see “The Pro-
gramming Assistant Dialog” on page 225 of Formulas & Programming).

As you can see Panorama has hundreds of commands that can be used in a procedure — in fact, it has a com-
plete programming language. If you’re a developer you’ll love the power and flexibility at your fingertips
(you can even program in PHP, Perl, Ruby, Python, AppleScript or shell scripts). If you don’t have program-
ming experience you’ll find that Panorama’s step -by-step approach makes it easy to learn. The fundamentals
of Panorama’s programming language and tools are described starting with “Introduction to (Panorama)
Programming” on page 203 of Formulas & Programming.

Creating a New Procedure from Scratch

In addition to creating procedures with the recorder, you can also create them from scratch. To demonstrate
this, I’ll create a simple procedure that displays a map of the current address. This is easy to do because Pan-
orama has a built-in command to display a map. To create a new procedure, right click on the View menu
and choose New Procedure (if you have a one button mouse, hold down the Control key).

right click or hold down control key to create 
procedure in a separate window



Page 52 Panorama Tutorial
I’ll simply call my new procedure Map.

Panorama creates a new, empty procedure, ready for whatever I want to put into it.

To find out how to display a map I use the Programming Assistant (Edit menu).
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The command I want is openmapwindow, so I double click on that line to insert it into my new procedure.

This command has eight parameters, but only the first four are required. So I start by deleting the last four
parameters. Then I edit the first four parameters to match the actual field names in this particular mailing list
database. 

My program is complete … just one line. To test it, I can either go back to the data sheet and choose Map from
the Action menu, or simply press the Run tool. Panorama will open a new window showing the location of
the current address in the data base.

Not every procedure is quite this simple, but if you take a step-by-step approach you’ll be amazed at what
you can do.
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Creating a Form for Printing Mailing Labels

Printing mailing labels is a common task. Many types of peel-off labels are available commercially. Panorama
already knows the dimensions of many popular labels and can do most of the work for you. The first step in
setting up a mailing label is to create a form to hold the label. A form is like a sheet of paper that you can
draw on (see “Introduction to Forms” on page 481 of the Panorama Handbook). You can place graphics, text
and data on the form to create labels, invoices, statements, or virtually anything else. To create a new form
select New Form from the View menu.

A dialog box appears asking for more information about the new form you want to create. Type in a name for
the new form (we used the name Mailing Labels, but you can choose any name up to 25 characters long).
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The dialog gives you three options when creating a new form — a blank form, a mailing label and a report.
Press the Quick Label button. The Quick Label dialog appears, allowing you to define the dimensions of the
mailing label you want to print on.
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In the center of the dialog is a pop-up menu that lists many popular labels. The most popular label is the
Avery 5160 which contains 30 labels per page in three columns of 10 labels.
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When you release the mouse the updated label dimensions appear. (You may also see an alert telling you that
the largest possible printable page area must be set in the Page Setup dialog. If you see this message you
should make sure Page Setup is configured to use as much of the page as possible, with the minimum possi-
ble margins.)

Press the OK button after the dimensions are set up.

Once the label dimensions are set up, the next step is to set up the text that will be printed on the label. A sec-
ond dialog box will appear with a list of fields on the left. You’ll build the template for your label on the right.
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Start by double clicking on the First field, then press the Space Bar.

Now double click on the Last field, then press the Return key.

Double click on the Address field, then press the Return key.

Double click on the City field, then press the comma key and the Space Bar.

Finish the label by double clicking on the State field, pressing the Space Bar and then double clicking on the
Zip field.

˙

¥

¥

, ˙

˙
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You can choose the font and size you want to use now or later.

Press OK when the label design is complete.

Panorama now shows you the finished template for the label. The label appears on special “tiles” that control
the size and spacing of the labels (see “Tiles In Action” on page 1076 of the Panorama Handbook for a complete
description of tiles).

tile

tile

tile
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Previewing the Labels

To see how the page of labels would look before printing, choose Preview from the File Menu. If this is the
first time the labels have been previewed or printed, the Page Setup dialog will appear. If this happens, just
press OK to skip to the preview window. The Print Preview window will show a reduced view of an entire
page of labels.

You can click on the magnifying glass tool to see the report life-size, and click on the Next Page tool to pre-
view the next page.

When you are done looking at the preview, click on the window’s close box. To learn more about the Print
Preview window see “Print Preview” on page 1056 of the Panorama Handbook.
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Printing the Labels

To print your mailing labels, first make sure that the correct printer is selected. Make sure the labels are set up
in the printer, then choose Print from the File Menu.

If you don’t want to print all of the labels, use the Find/Select command to select the addresses you do want
to print. Use the Select button so that only the addresses you want to print are visible (see “Selecting Instead
Of Finding” on page 30). Once the correct addresses are selected, use the Print command to print the labels.
After the labels are printed, use the Select All command to make all of the addresses visible again.

Switching Between Forms and the Data Sheet

To switch back to the data sheet select Data Sheet from the View menu.

Panorama will switch the window from the mailing label back to the data sheet.



Page 62 Panorama Tutorial
The View menu lists every possible view of your database, and also allows you to create new views. To
switch back to the mailing label, choose the name of the form containing the label from the menu.

Your database can contain many different forms, each displaying the data a different way (see “Introduction
to Forms” on page 481 of the Panorama Handbook).

Creating a Data Entry Form

A form is not limited to displaying and printing data, it can also be set up for data entry. Using a form allows
you to lay out the fields any way you like. You are not limited to the row and column format used by the data
sheet. 

To create a new form view you’ll use the View menu. You’re going to create the form in a new window. To do
this you must hold down the Alt key if you are using a Windows PC, if you are using a Macintosh hold down
the Control key. Either way, select New Form from the View menu.

Panorama will ask you for the name of the new form. You can use any name you like up to 25 characters, we
chose the name Entry.
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When you press the Blank Form button Panorama will create a new, empty, form. Since you pressed the Alt
key (PC) or the Control key (Mac) when using the View menu, Panorama creates the form in a new window,
leaving the data sheet also open in the back (see “Opening More Than One Window Per Database” on
page 169 of the Panorama Handbook to learn more about window management).

The tool palette on the left side of the window contains tools for creating and manipulating graphic objects
on the form. The most commonly used tools are shown below.

switch between graphics editing and data editing
pointer for selecting graphic objects
turn cross hair on/off (to help alignment)
magnify/reduce
create data cell object (database field)
create text object
create line object
create rectangle object
create rectangle object with round corners
create oval/circle object
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Creating Graphic Objects

Before you actually start creating the data entry form let’s practice a bit with using these tools. Start by select-
ing the Oval tool.

Now move the cursor onto the form and drag the mouse across the surface of the form to define the location
and size of the new object (the dragging motion is shown by the dashed arrow in the illustration below). A
gray outline of the new object will follow the mouse.

When you release the mouse, the new object will appear.
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Each time you drag across the form you will create a new shape. Create several shapes as shown below (these
objects are just for experimentation, so don’t worry about the exact position and size).

When you are finished creating shapes, click on the Pointer tool.

Don’t forget to click on the Pointer tool when you are done! If you don’t, the next time you click you will
create another graphic object. To learn more about creating graphic objects see “Creating a Graphic Object”
on page 494 of the Panorama Handbook.

Selecting and Moving a Graphic Object

To select a graphic object simply click on it with the Pointer tool selected. Four “handles” appear at the cor-
ners to show that the object is selected (see “Selecting a Single Object” on page 501 of the Panorama Handbook).

click on the object you want to select

handles
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To move an object click on it and drag to the new position (see “Moving a Single Object” on page 508 of the
Panorama Handbook).

For fine adjustments you can use the arrow keys (¯, ˘, ¿, ˜) to nudge selected objects into position.
Each time you press an arrow key, the object (or objects) moves one pixel in the direction of the arrow (see
“Nudging an Object (or Objects)” on page 509 of the Panorama Handbook).

Adjusting the Size of a Graphic Object

To change the size of an object, first select the object with the Pointer tool. Then use the mouse to drag one of
the corner handles. As you drag the handle, an outline of the object will follow the mouse.
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Release the mouse when the corner is in the correct spot (see “Changing the Size of a Single Object” on
page 513 of the Panorama Handbook).

The arrow keys (¯, ˘, ¿, ˜) usually nudge the entire object. However, after you click or drag a handle,
the arrow keys will nudge just that handle. Each time you press an arrow key the handle will move one pixel
in the direction of the arrow. In other words, each time you press an arrow key the object will grow (or
shrink) one pixel in the direction of the arrow (see “Nudging the Size of an Object” on page 513 of the Pan-
orama Handbook). You can also adjust the position and size of the object numerically with a dialog, see “View-
ing and Setting Exact Object Dimensions” on page 512 to learn how.

Changing an Objects Appearance

The new objects you have created are white with a black border. You can change it to Solid (or Hollow) with
the Graphics menu (see “Solid, Outline and Hollow Objects” on page 520 of the Panorama Handbook).
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After you make your selection the object will change to the selected pattern, in this case solid fill.

current fill pattern (solid)
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You can also use the Graphic Control Strip (on the bottom of the window next to the horizontal scroll bar, see
“The Graphic Control Strip” on page 505 of the Panorama Handbook) to change the appearance of the selected
objects. Another way to change the selected object to solid black is to use the fill pattern menu (see “Fill Pat-
tern” on page 521). This menu has 40 different patterns to choose from.

click to pop-up the fill pattern menu

solid black
solid whitetransparent

50% gray
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To change the color of the selected object use the color menu (see “Color” on page 526 of the Panorama Hand-
book).

After you make your selection the object will change to the selected color.

current color (black) new color (blue)
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If you want to choose a color that is not on the palette hold down the Control key while clicking on the color
swatch in the control strip (On PC systems you should Right-Click on the swatch instead of holding down
the Control key). The standard system color dialog will appear.

Choose the color you want and press OK.

You can also adjust the line pattern (see “Line Pattern” on page 523 of the Panorama Handbook) and the line
width (see “Line Width” on page 525) of the selected object(s), and you can copy the color from one object to
another (see “Copying and Pasting Colors” on page 528).

Creating Text Objects

To add a piece of text to your form start by clicking on the Text tool.
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Now move the mouse to the position where you want the text to appear (you can adjust the position later)
and click the mouse.

Now use the keyboard to type in the text.

As you type each character, the click text object automatically expands. To add another line of text press the
Return key. When you’re done creating text you can click on another spot to create another text object or you
can click on the Pointer tool.

The text object you just created is called click text, because you click to create it. Panorama has another type
of text object called an auto-wrap text object. Instead of expanding automatically as you type an auto-wrap
text object is a fixed size, with the text wrapping inside the object. To create an auto-wrap text object click on
one corner of where you want the object to appear and then drag to the opposite corner.

click where you want the text to appear
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When you release the mouse a dotted box appears for you to type into. 

Whatever you type will wrap inside of the box.

When you’re done creating text you can click or click-drag on another spot to create another text object or you
can click on the Pointer tool.
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Changing the Font and Size

To change the font and size of the selected object you can use the Graphic Control Strip or you can use the
Text menu (see “Text Font, Size and Style” on page 593 of the Panorama Handbook). The illustration below
shows the auto-wrap text object being changed from 12 point to 9 point.

Here’s the revised text object.

Within a single text object all of the text must be the same font, size, style and color. If you want to mix differ-
ent text appearance within a single object you must use Panorama’s Word Processor SuperObject (see “Word
Processor SuperObject” on page 673 of the Panorama Handbook).

current text size
current font
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Editing a Text Object

To edit a text object simply select the Text tool and click or drag on the object (see “Editing Fixed Text” on
page 590 of the Panorama Handbook). With this tool you can edit the text object just like any other text - click to
select an insertion point, double click to select a word, etc.

Creating Data Cell Objects

Panorama has two different types of objects for editing data (see “Types of Data Editing Objects” on page 632
of the Panorama Handbook). Right now you’re going to learn about data cells, which allow data fields to be
edited with a pop-up input box very similar to the data sheet (see “Entering Data Into Your New Database”
on page 7 and “The Input Box” on page 272). To create a data cell start by selecting the Data Cell tool (see
“Working with Data Cell Objects” on page 635).

Drag the mouse across the form in the spot where you want to create the data cell.
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When you release the mouse the data cell is created. It is automatically assigned to the first field in the data-
base, which in this database is First.

Each additional data cell you create will be assigned to the next available field in the database.

To change the field a data cell is assigned to make sure the Data Cell tool is selected and move the mouse
over the data cell object. When the mouse is over the object the arrow turns into a little menu icon.

When you see this icon you can press the mouse button to see a pop-up menu of the fields in the database.
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Select the field you want assigned to the data cell from the pop-up menu.

Panorama has another type of graphic object for editing data - the Text Editor SuperObject. To learn more
about this type of object see “Text Editor SuperObject” on page 639 of the Panorama Handbook.

Aligning Multiple Objects

I don’t know about you, but those raggedy looking data cells are really bothering me! Fortunately Panorama
has tools that can make this objects nice and neat in a hurry. Start by selecting the Pointer tool.

Now start on an empty spot on the form and drag the mouse diagonally across all four objects. The dotted
rectangle should surround the objects.

When you release the mouse all four objects will be selected (see “Selecting Multiple Objects at Once” on
page 502 of the Panorama Handbook).

changed from Address to Phone
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To align the left and right edges of the objects choose Align Objects from the Arrange menu (see “Aligning
Objects” on page 553 of the Panorama Handbook). The dialog gives you eight different alignment choices —
pick Left & Right.

When you press the Align button the left and right edges of the objects are brought into perfect alignment.

To set the height of all of the objects to 15 pixels choose Dimensions from the Edit menu (see “Setting Exact
Dimensions of Multiple Objects” on page 550 of the Panorama Handbook). Select the Pixels radio button and
type in 15 for the height (just 15, not +15).

When you press OK all of the objects will be adjusted to 15 pixels.
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To vertically space the objects evenly choose the Spacing command from the Arrange menu (see “Adjusting
Spacing Between Multiple Objects” on page 556 of the Panorama Handbook). Click on the Vertical option and
set the spacing you want between each object (a pixel is one screen dot, or 1/72nd of an inch).

The data cells are now lined up nice and neat.

Before we call it a day let’s make one final adjustment. Hold down the Shift key and drag the bottom right
handle of the bottom object to the right.

When you release the mouse all four objects will expand. This feature is called cluster resize (see “Cluster
Resize” on page 541 of the Panorama Handbook for additional examples) and is very handy for adjusting col-
umns of objects.

In a few minutes you’ll learn a method to create data cell objects in a nice neat column or row in the first
place, making the technique shown above unnecessary. However, you’ll still find the techniques described
above useful in many circumstances.
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Using Data Cells to Edit Data

So far you’ve managed to make four boxes with field names on them — perhaps that doesn’t seem very use-
ful. To activate these cells you must switch the form from Graphic Design Mode to Data Access Mode.

In this mode the rulers disappear and the tool palette switches from graphics tools to data navigation tools
(see “Moving From Record to Record” on page 265 and “Browsing the Database With a Form” on page 488 of
the Panorama Handbook). Most importantly, the data cells now display information from the database itself.

database fields



Page 81
If you adjust the windows so that you can see both the data sheet and the form you can see that the form is
displaying the same information that the data sheet is displaying.

If you double click on one of the data cells you can edit the data, just as you could in the data sheet (see
“Entering Data Into Your New Database” on page 7 of this tutorial as well as “The Input Box” on page 272 of
the Panorama Handbook).
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When you press the Enter key the new data will appear in both the form and the data sheet.

The same process works in reverse also — any data you enter into the data sheet will also appear in any
forms that are open.

Building the Data Entry Form

Enough practice — it’s time to start building the actual data entry form. Start by switching the form back to
Graphic Design Mode.
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We’re going to start over in this form, so the first step is to erase all of the practice objects you have created. To
do that choose Select All Objects from the Edit menu, then Clear from the Edit menu (or press the Delete
key). Now you’ve got an empty form.

Now click the mouse in the upper left hand corner of the form, about 1/16th of an inch from the top and left
hand sides.

Now choose the Auto Cell Layout command from the Arrange menu. This command is going to create a neat
column of data cells for us (see “Automatically Creating Rows or Columns of Data Cells or Text Editor Super-
Objects” on page 662 of the Panorama Handbook). This dialog controls how the data cells are generated. Start
by pressing the Select All Fields button. Then set the Spacing (Pixels) option to 1.
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When you press the OK button Panorama will automatically create a column of data cells (starting at the
point where you clicked the mouse).

All of the objects are selected. To begin working on the objects separately click on any blank spot to de-select
the objects.

Using a combination of dragging and the arrow keys (¯, ˘, ¿, ˜) move the objects so that the First and
Last name objects are on the same line and the City, State and Zip objects are the same line. Usually the best
technique is to drag the object approximately into place and then use the arrow keys to nudge it exactly into
position. If you need to review the techniques for dragging and nudging objects see “Moving a Single Object”
on page 508 and “Nudging an Object (or Objects)” on page 509 of the Panorama Handbook. You may also find
“Viewing and Setting Exact Object Dimensions” on page 512 useful.

When you nudge an object with the arrow keys (¯, ˘, ¿, ˜) blue lines will appear when the object is
aligned with other objects. When you are finished the result should look like this.
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Next drag and nudge the Phone object up under the City, State and Zip objects. When you drag the Phone
object hold down the Shift key so that Panorama will drag the object straight up with no slip to the left or
right (see “Moving a Single Object” on page 508 of the Panorama Handbook). Then use the ¿ and ˜ arrow
keys to nudge it into final position.

Again holding down the Shift key, drag the lower right hand handle to the right, expanding the width of the
Phone object.

Then use the ¯ and ˘ arrow keys to nudge the width of the object until it matches the combined width of
the City, State and Zip objects. The blue alignment lines appear when the objects are aligned. You may also
find it useful to use the crosshair cursor to check the alignment (see “Nudging to the Crosshair Cursor” on
page 515 of the Panorama Handbook).

Then use the same techniques to adjust the width of the Address cell. Alternatively you can select the
Address and Phone objects (see “Selecting Multiple Objects at Once” on page 502 of the Panorama Handbook)
and then use the Align command with the Left & Right option to adjust the width. Either way the form
should now look like this.
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Drag the mouse around the bottom group of objects to select them (see “Selecting Multiple Objects at Once”
on page 502 of the Panorama Handbook).

While holding down the Shift key drag these objects up underneath the First and Last objects. After you’ve
dragged them close use the ¿ and ˜ arrow keys to nudge the objects into final position.

Finally drag and nudge the width of the Last name object to match the other objects.

As one last enhancement you’ll set the background color of the form. To do this use the Form Preferences
command in the Setup menu. The background color is set with a pop-up menu at the bottom of this dialog
(see “Form Background Colors” on page 582).
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Your new form is now complete. Use the Switch To Data Access Mode tool to prepare for displaying and
entering data, and adjust the window size and position so that both the data sheet and form are visible at the
same time.

The form window has a tool palette and scroll bars that aren’t really necessary. To get rid of them select the
Window Tweak command from the Form Tools submenu of the Wizard menu (see “Turning Window Com-
ponents On and Off (Window Tweak Wizard)” on page 150 of the Panorama Handbook). The tool palette and
scroll bars are now removed.
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If you ever need to get the scroll bars and tool palette back again (for example to modify the form) simply
select the Window Tweak command again. Another option is to close the form window and then re-open it
with the View menu, which will also restore the tools and scroll bars.

Now that the form is complete be sure to Save your work. (In fact it really would have been a good idea to
save two or three times while you were working on the form. Since Panorama saves so quickly there’s no rea-
son not to save early and often.) Panorama saves the window positions along with the data and graphics
(assuming you checked the Save Window Positions option when you originally saved the file, see “Saving
Window Positions” on page 64 of the Panorama Handbook), so if you close the file and then re-open it the form
window and data sheet windows will reappear in the same places, ready to go.

The new form you have created only scratches the surface of the capabilities available for building forms. To
see a more sophisticated example use the Example Launcher wizard (Wizards>Demos>Example Launcher)
to open the 106th Congress database. This form uses what is called view-as-list mode, which allows a form to
display more than one record at a time (kind of a cross between the data sheet and a regular form. See “View-
As-List Forms” on page 899 of the Panorama Handbook to learn how to create this type of form.
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To see an example of a more traditional form press the Contact Info or Bio button. (See “Push Buttons” on
page 823 of the Panorama Handbook to learn how to create a button.) Pressing either button opens a form in a
new window.

All of these forms use Flash Art to display a photograph (see “Flash Art™” on page 750 of the Panorama
Handbook). You can also show and play a QuickTime movie in a form (see “Displaying Movies in a Form” on
page 819 of the Panorama Handbook).

Writing a Letter to Someone in the Mailing List

Panorama includes a pre-built database for handling general word processing chores — the Mini Correspon-
dence wizard (see “Using the Mini Correspondence Wizard” on page 727 of the Panorama Handbook). This
database may be used for general correspondence (letters, memos, etc.) and to create mail merge letters that
are customized and sent to a group of recipients. To write a letter to a person in your mailing list database,
first locate and click on that person.

click on the person you want to write a letter to
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Now open the Mini Correspondence wizard.

The wizard will ask you if you want to create a new letter to Sharon Blair.

Press the Yes button to create the new letter. The wizard will automatically fill in the name and address in the
new letter.
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At this point all you need to do is type in the body of the letter. Just start typing.

When you are finished typing in the letter press the Enter key. Panorama will display a preview of the actual
letter, including the address, greeting and salutation.
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If you want to print this letter use the Print This Letter… command in the Letter menu.

To learn more about editing a word processing document (including setting margins, tabs, fonts, styles and
colors) see “Using the Word Processor” on page 677 of the Panorama Handbook.

Printing a Mail Merge Letter

You can take the same letter you just created and send it to multiple recipients — for example we could send
it to everyone in the 619 area code. Start by going back to the My Mailing List database and selecting the
members of congress from California (see “The Find/Select Dialog” on page 336 of the Panorama Handbook)
and searching for (619).

As you can see there are 4 people in this area code in the mailing list. Press the Select button to select them in
the data sheet.
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Now go back to the Mini Correspondence database and pull down the Letter menu. The last item in this
menu will print a customized letter to each selected person in the My Mailing List database.

The wizard will print 4 customized letters.

See “Printing a Mail Merge Letter” on page 732 of the Panorama Handbook to learn more about printing mass
mailings with Panorama.
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Tidying Up

Your mailing list database is complete, so now is the time to save your work permanently. Choose Quit from
the Panorama menu (OS X) or File menu (Windows). If you have made any changes to your database since
the last time it was saved, Panorama will ask you if you wish to save the database. You do, so click the Save
button.

Congratulations! You’ve successfully created and used your first Panorama database (you were following
along on your computer, right?). Now that you’ve mastered the basics you’re ready to move on to some more
advanced techniques.

Extra Credit — Importing, Cleaning up and Adding a List of Names to the Mailing List

Suppose a colleague has sent you a spreadsheet with names you need to add to your mailing list. The names
are formatted differently from your list, but I’ll show you how Panorama can take care of that. (The spread-
sheet below is in Apple’s Numbers program, but the techniques I’m about to show you also works with
Microsoft Excel.)
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Since the data is in the wrong format I can’t import it directly into my mailing list. Instead, I’ll import it into a
new database, fix up the data, and then add it to the mailing list. I’ll start by opening the New Database Wiz-
ard, selecting all of the data in the spreadsheet, and then dragging it onto the wizard. (If you want to follow
along you can find the New Members spreadsheet by opening the New Database Wizard, then choosing
Show Sample Text Files from the Special menu.

Note: If you’re using a Windows PC system dragging to the New Database Wizard is not enabled. Instead,
you’ll need to select all of the data in the spreadsheet, copy it into the clipboard, then go to the New Database
Wizard and press the Import From Clipboard button.

Once the data has been dragged (or copied) to the new database wizard, the wizard will parse the data into
three fields. Since in this example the first row of the data contained the field names, I am ready to go. Other-
wise I would need to edit the field names now. 

To actually create the new database I press the Make New Database button.
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Here’s the data.

Now that the data has been transferred to Panorama I can get to work on fixing the data so that it matches my
mailing list. The first step is to fix the capitalization — I hate all caps! To do that I choose Manipulate Data in
Field from the Field menu.

As shown above, click the + button to add a manipulation row to the dialog. Then click on the pop-up menu
to change the selected manipulation to Modify Capitalization.

click + to get started

click for pop-up menu, change to Modify Capitalization
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Now I change All Caps to Word Caps. The instant preview shows that the names now look the way I want
them to.

I press the Apply button to actually change the database, then I repeat the same steps for the Address field.
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Now I need to split the names into separate first and last names, and the addresses into separate street
address, city, state and zip fields. I start by clicking anywhere in the Name field, then choosing Split Field
from the Fields menu. Using the dialog, choose the options to split the first and last names.

Actually splitting the field just takes a fraction of a second.

The first and last names are reversed so I click on the column header…

and drag it into position,

1) Specify how field will be split

2) Type in new field names

3) Check preview

4) Split the field
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Splitting the address is similar to splitting the name. Again I start by clicking anywhere in the Address field
and choosing Split Field from the Fields menu. It will take three passes to split this into four fields, I’ll start
with the zip code field, as shown here.

Once again, actually splitting the field only takes a fraction of a second.

Splitting off the state is pretty much the same as splitting off the zip except that the split is at the last comma
instead of the last space. (The states need to be all caps, but I’ll fix that in a moment.)

Finally I split off the city, also at the last comma.

1) Specify how field will be split

2) Type in new field names

3) Check preview

4) Split the field
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Here’s the finished result, with all the fields split. (To learn more about splitting fields, see “Splitting a Field”
on page 201 of the Panorama Handbook. You can also merge fields, see “Merging Adjacent Fields” on page 207
of the Panorama Handbook.)

Before I transfer the data to my mailing list I need to convert the State field to all caps. To do that I click any-
where in the field, choose Manipulate Data in Field, then set up the dialog to modify the capitalization:

I press Apply and the data is ready to transfer.
ToT
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To actually transfer the data I first need to save it, so I choose Save from the File menu and give the new file a
name.

I’m done with this new database, so I can close it and get back to my original My Mailing List database.
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With the My Mailing List database active, I choose Open File from the File menu, then choose the option to
append the data as shown below.

The data has been transferred from the spreadsheet to the mailing list database, without any retyping and
without any programming or formulas.

Note: If you are willing to write some formulas, it would be possible to use the Text Import Wizard to
directly import data like this without having to create an intermediate database. To learn how, see “Re-
Arranging Imported Data” on page 93 of the Panorama Handbook.

2) Tell Panorama to 
append instead of 
opening the file in a 
separate window

1) Select file to 
append to current 
database

3) Match fields by 
name (if unchecked 
fields will be matched 
by their order)

4) Press Open to append data
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Extra Credit — Transferring Data with VCards (Mac only)

In this section we’ll export a VCard to Apple’s Address Book application. A properly configured Panorama
database can exchange data with any VCard compatible application. In this case, the New Database wizard
has done the configuration for us (see ““Generic” Fields” on page 230 of the Panorama Handbook to learn how
to do this configuration yourself). The first step is to click on the record we want to transfer, in this case Chris-
tina Gutierrez.

Open the VCard Wizard, which you’ll find in the Utility submenu of the Wizard menu. The wizard displays
the name, address and phone number of the currently selected person.

To transfer Ms. Gutierrez to the Address Book, drag the tiny book icon onto the Address Book window.
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The Address Book program will ask you to confirm that you want to add this person.

Press OK to add her to the Address Book.

Drag the other way to transfer from the Address Book to your database.

John Kuttel is automatically added to the database.

The VCard wizard can also import and export groups of VCards at once. For more informations see “Using
Generic Fields with the VCard Wizard” on page 237 of the Panorama Handbook.
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Lesson 2: Building and Organizing a Checkbook
Checkbook

Now that you’ve created your first simple mailing list database, you’re ready to try something more compli-
cated. In this lesson you’ll build and use a database for keeping track of a checkbook. Start by launching Pan-
orama and the New Database Wizard.

The checkbook database will have eight fields — Date, Check, Pay To, Category, Memo, Debit, Credit and
Balance. In the Lesson 1 mailing list file all of the fields were text fields, but this checkbook database will
include text, dates and two different types of numbers. I’ll start by clicking on the small yellow star and
choosing Date from the pop-up menu.

Choosing from this menu automatically sets up all of the attributes for the field (of course you can also set up
these attributes separately.

The next field will contain check numbers. Set it up using the steps shown below.

click here to choose from a list of the most common field names

name, type and other attributes fill in automatically

1) Press + to add another field

2) Type in field name 3) Switch to numeric
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The next three fields are text fields, so I just press the + button to add the field and type in the field names.
(Panorama displays a warning because the Pay To field name contains a space. Field names with spaces or
punctuation require special handling when used in a formula. Since I’m not planning to use Pay To in a for-
mula, I’ll ignore this error.)

I’ll click the Ignore Warnings checkbox to suppress the warning.

Like the Check field, the Debit field is numeric. The Debit Field, however, has two digits after the decimal
point (or you might want to use the Float or Money options, see “Numeric Data” on page 249 of the Pan-
orama Handbook).

Warning appears because of blank in Pay To field name

1) Press + to add another field

2) Type in field name

3) Switch to numeric

4) 2 digits after the decimal point
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After adding the Credit and Balance fields the setup is complete.

Press Make New Database to actually create the new checkbook database.

Panorama creates a new, empty database with the specified fields. It then asks if you would like to fill the
database with sample data (it doesn’t usually do this, but has been specially programmed with sample data
for some of the tutorial databases).
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Press Yes to load the database with sample data that will be used in this tutorial.

You may want to adjust the widths of some of the columns (see “Adjusting Column Widths, Font, Size and
Background Color” on page 19).

Before continuing you should use the Save command in the File menu to save your new creation. The first
time you save any file Panorama will ask you to give it a name. You’ll also want to check the Save Window
Positions option if it is not already checked. When everything is set up press the Save button. (To see what
this dialog looks like on the PC see “Saving Your Work” on page 12.)

select folder you want to save file intype in name of file

tell Panorama to save window positions
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Analyzing the Checkbook

In the next few sections you’ll learn several techniques for extracting useful information from any database. 

Selecting Data

Suppose I’d like to look at all office supply expenditures. Since one office supply check is already visible, all I
have to do is right click on the cell and choose Select Same. (If you only have a one button mouse then hold
down the Control key and click on the cell.)

Panorama will select the 73 checks for office supplies in the database. All of the other checks will become tem-
porarily invisible.
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To see only the records in October, right click on any cell in that month and choose Select Same Month.

Now all 44 records in October are shown.
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To see only checks for Office Supplies in October, open the Find/Select dialog (from the Records>Search
menu), then set up the options as shown below.

Press the Select button (or the Enter key) to actually select the 8 checks for office supply expenses in Octo-
ber 1998.

When you want to see all of the checks again, choose Select All from the Records>Search menu. You can also
undo the sixteen most recent selections with the Undo command in the Edit menu (see “Undo Select” on
page 359 of the Panorama Handbook).
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Calculating the Grand Total

To calculate the grand total of all the checks in the database simply right click anywhere in the Debit field and
choose Column Stats.

A small pop-up window displays the total, along with other information about the values in this field.

If only a subset of records is selected then the statistics will reflect that subset. For example, if only records
from July are selected then the total will include only checks from July.

Analyzing and Calculating Subtotals

Panorama has a special tool for analyzing and summarizing database information, the Analyze Data dialog.
To open this dialog, choose Summarize & Analyze from the Records>Analyze menu.



Page 113
This dialog allows you to use pop-up menus to specify how you want the database to be summarized and
calculations to be performed.

The top section of the dialog, Summary & Analysis Options, is where the Group/Calculate/Outline analysis is
set up. When you first open the dialog this section contains three rows that are preset for summary (group),
total (calculate) and outline level:
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Start by choosing the field you want to summarize by. For date columns you will also have a choice of peri-
ods (day, month, year, etc.)

Once you've selected the summarization field the dialog will show you how many different groups of data
are associated with that field, and also list all of the groups in the Group Preview area below.

Next, use the pop-up menu in the second row to choose a column you want to perform calculations on. (In
addition to totals, you can also calculate counts, averages, minimums and maximums.) Once you've chosen a
column the dialog will show you the grand total for this column.

The final row allows you to control what level of the outline is initially displayed. It defaults to the primary
summary field, so you can usually just leave it as-is. However you have a choice of any field you have sum-
marized by or you can elect to include the raw data in the display.
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To actually create the outline press the Apply button. Panorama will organize the database into an outline
with summary records for the groups you have specified.

The original data records are temporarily hidden. You’ll see how to bring them back later.

Multi-Level Summaries

The previous example create one summary level. Panorama can create up to seven nested summary levels,
for example Categories within Months, or Cities within States within Months within Years. To add an addi-
tional summary level, re-open the Summarize & Analyze dialog, then press the + button on the first row to
add a second summary level.

summaries for each month

grand total

click + to add another summary level
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Now use the pop-up menu to select the field to be summarized. The summary preview will show the groups
that will appear at this summary level.

The outline level pop-up menu now gives you the choice of either summary level or raw data. All levels at
and above the selected level will be display.
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Pressing the Apply button organizes the database into a multi-level outline.

Scrolling down to the bottom of the database shows the grand total for the entire database.

Using the same technique you can add up to seven nested summary levels. See “Summaries and Outlines”
on page 365 of the Panorama Handbook to learn more about analyzing data with summaries.

summaries by month

sub summaries by category (within month)

grand total
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Expanding and Collapsing the Summary Outline

A unique feature of Panorama is that summaries aren’t just static on a report, they can be dynamically
expanded or collapse to show more or less detail. You can “zoom out” to look for major trends, then “zoom
in” to examine specific details. We call this collapsing (zoom out) and expanding (zoom in). To expand a par-
ticular summary, click on the summary, then click on the Expand tool or right click on the summary and
choose Expand One Level of Detail from the pop-up menu (you can right click on any cell in the line).

Panorama makes the next level of detail visible.

click on Expand tool
or right click and choose Expand One Level of Detail
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If the database has more than one summary level you can repeat the process all the way down to the raw
data.

In this example we are now down to the raw data for purchases in July 1998.
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To collapse a summary, click on it and then click on the Collapse tool. Or, right click and choose Collapse
Underlying Detail.

Another way to collapse is to right-click on a detail record, then choose Collapse this to. This is especially
handy if the summary record you want to collapse isn’t currently visible in the window.

click on

or right click and choose Collapse Underlying Detail

Collapse
tool
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The example above shows doing this with a data record, but this trick works on any record except for the
final grand total. The menu adjusts to show exactly what is about to be collapsed, as shown below.

At the start of this section we showed how to expand one level at a time. You can also click on a summary and
ask Panorama to expand it all the way to the raw data, all in one step. To do this either click on the Expand
All tool, or right click on the summary and choose Expand ALL Underlying Detail.

click on Expand All tool
or right click and choose Expand ALL Underlying Detail
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This makes all subsummaries and raw detail associated with this summary record visible. In the example
below, we now can see all of the data and sub-summaries for November 1998.

Expanding and Collapsing the Overall Summary Outline

In the previous section you learned how to collapse and expand individual summary records. Sometimes,
however, you’ll want to expand or collapse the entire database as a whole. The fastest way to do this is with
the Data Sheet Context menu. Simply right click anywhere in the data sheet and choose the outline level you
want to see.

right click anywhere in data sheet

then choose the level you want to see
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If you choose RAW DATA then everything will be visible — the original data, and all summary records.

If you choose GRAND TOTAL then only one record will be visible — the grand total summary record. The
choices in between will display varying levels of summary detail.

A second way to expand or collapse the entire database is to use the Summary Outline Level dialog (in the
Records->Analyze submenu). See “Expanding and Collapsing the Overall Summary Outline” on page 380 of
the Panorama Handbook to learn how to use this dialog.
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Getting Rid of Summary Records

When you’re finished with summary records, you can simply choose Records->Analyze->Remove All Sum-
maries to get rid of them. All of the summary records will disappear, and you can get back to working with
your original data. This command is also available in the right-click context menu.

Ranking Summaries

Panorama normally generates summaries in alphabetical order. By adding an extra rule to the Summarize &
Analyze dialog you can tell Panorama to rank the summaries by value. For example, if you are summarizing
by month they could be ranked to show the month with the highest sales (or spending, etc.) first, then the sec-
ond highest etc. Start by clicking on the + button in the outline level row of the dialog.
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Panorama assumes that you want to rank by the field that is being totalled in this analysis (in this case Debit),
but you can choose another field if you wish. Then press the Apply button to see the ranked summaries.

For multi-level nested summaries you can use the outline level pop-up menu to pick which level is ranked.
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Whatever level you specified will be ranked. In this example, the category summaries are ranked within each
month.
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Ranking the summaries doesn’t affect the ability to expand detail. For example, now that the summaries are
ranked we can easily see that the purchasing category in May was a bit higher than usual. To find out why,
right click on the record and choose Expand One Level of Detail (or just click and choose the Expand tool).

Now we can see that there was a large purchase made to Stamford Manufacturing, raising the purchasing in
that month.

The ability to “zoom” in and out like this is a great tool for actually understanding your data.
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Analyzing Data with a Crosstab

In addition to the Group command Panorama has another powerful tool for summarizing data — crosstabs.
For your next trick you’ll create a crosstab table that displays spending by category vs. month. To create a
new crosstab view you’ll use the View menu. If you are using a Windows PC hold down the Alt key, if you
are using a Macintosh hold down the Control key. Either way, select New Crosstab from the View menu.

Type in the name of the new crosstab, in this case Monthly Spending, and then press the OK button.
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Panorama will create the new crosstab window, and then immediately open the Crosstab dialog. This dialog
contains a list of the database fields on the left hand side. On the right hand side is a list of fields in the
crosstab and a diagram of the crosstab layout (both empty to start).

diagram of
crosstab layout
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To tell Panorama to list months across the top of the crosstab click on Date and then press the »Copy» button
(or double click on Date).

To separate the crosstab into one month per column use the pop-up menu to switch from Day to Month.
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Next you need to specify the field that will appear down the left hand side of the crosstab table. Click on Cat-
egory and then press the »Copy» button (or double click on Category).

Next you must specify what goes in the middle of the crosstab table. Click on Debit and then press the
»Copy» button (or double click on Debit).
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Finally, click the Total radio button so that the crosstab will add up the checks instead of counting them.

Press the OK button. Panorama will think for a few seconds, then the crosstab table will appear in a new win-
dow slightly below and to the right of the data sheet window (see “Opening More Than One Window Per
Database” on page 169 of the Panorama Handbook). The crosstab table displays a summary of the information
in the database, showing categories down the left hand side and months across the top (see “Crosstabs” on
page 415 of the Panorama Handbook).
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Just as with the Data Sheet you can adjust the text size and column widths of the crosstab table (see “Adjust-
ing Column Widths, Font, Size and Background Color” on page 19).

You can split the window into two separate panes by dragging the splitter to the right. The splitter is the
small black rectangle to the left of the horizontal scroll bar (see “Splitting a Window” on page 145 of the Pan-
orama Handbook).
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Once the window has been split in two you can horizontally scroll each pane separately. If you scroll all the
way to the right you will see the overall totals for each category.

To learn more about crosstabs see “Crosstabs” on page 415 of the Panorama Handbook.

totals for each category
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Auditing the Crosstab Table

As you examine a crosstab you may find that you need to check out the backup detail behind a certain num-
ber. Doing this is easy—just click on the number and then click the Select Original Data tool. For example,
suppose you want to see the individual checks written for purchases in November of 1998. Simply click on
the Nov 98 Purchases cell and click on the tool.
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After you click on the tool the data sheet shows the detail for the crosstab cell you clicked on, in this case the
nine checks made for purchase in November of 1998.
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You can use the Select Original Data tool with any cell in the crosstab. In this illustration it has been used to
select all Fixed Assets regardless of month.
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If you click on one of the cells in the bottom line and use the Select Original Data tool Panorama will select
an entire month of checks, in this case all 43 checks written in February of 1998.

When you are done with the crosstab close the window and, if necessary, use Select All in the Search menu to
make all the records in the data sheet visible again (see “Selecting All Records” on page 38). You can open the
crosstab again later using the View menu. If the data has changed use the Calculate Crosstab tool to re-calcu-
late the table values.

To learn more about crosstabs see “Crosstabs” on page 415 of the Panorama Handbook.
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Making a Bar Chart

Someone once said that a chart is worth a thousand numbers. Ok, that’s not quite what they said, but let’s
create a chart anyway. Charts are usually displayed from summary records in the database, which are created
with the Summarize & Analyze dialog described earlier in this lesson (see “Analyzing and Calculating Sub-
totals” on page 112). Here’s how to set up this dialog to summarize the checkbook database by month.

When the Apply button is pressed, the summaries are calculated and the raw data disappears. Now we’re
ready to chart this information.

The next step in building a chart is to create a new form. If you are using a Windows PC hold down the Alt
key, if you are using a Macintosh hold down the Control key. Either way, select New Form from the View
menu (see “Creating a New Form” on page 487 of the Panorama Handbook).
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You know the drill by now — type in the name of the new form (up to 25 characters).

Press the Blank Form button to create the new form.
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Adjust the window size to approximately the size of the chart you want to make, then click on the Chart tool.

Move the mouse over the form and then drag from corner to corner to create the chart, just as you would to
create a rectangle or a data cell.
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Your new chart doesn’t look much like a chart yet, in fact it looks more like a dialog!

The buttons and pop-up menus in the dialog allow you to configure the chart. At a minimum, you must
select a legend field and at least one value field (see “Setting Up Legend and Value Fields” on page 998 of the
Panorama Handbook). In this case the legend field is already set to Date. Use the pop-up menu to set the value
field to Debit.

legend field

value field
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Switch to Data Access Mode to see the actual chart (see “Form Modes: Data Access vs. Graphic Design” on
page 485 of the Panorama Handbook).
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Customizing the Chart Appearance

Let’s dress up the chart a little bit. To do that switch back to Graphic Design Mode (see “Form Modes: Data
Access vs. Graphic Design” on page 485 of the Panorama Handbook). Then click on the chart and change the
font size to 9 point.

Now select the Output Pattern command from the Text menu.
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This command allows you to specify how the dates in the chart legend will be displayed. To display just the
abbreviated month name (Jan, Feb, Mar, etc.) type in Mon (see “Date Output Patterns” on page 255 of the
Panorama Handbook).

Use the color pop-up menu to select a different color for the chart bars (see “Graphic Attribute Icons” on
page 1017 of the Panorama Handbook).



Page 146 Panorama Tutorial
Click on the Grid option to display a dotted line from each tick mark.

To preview the chart’s appearance without going into Data Access Mode click on the preview flap in the
lower left hand corner of the chart object. The preview flap is the small triangle that looks like a turned up
page corner.

preview flap
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When in the preview mode you can use the extra fifth chart handle to adjust the margin where the chart leg-
ends appear.

When the form is switched to Data Access Mode the chart will immediately show any changes made to the
database.
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For example if you edit the summary value for March 1998 the chart will immediately update to reflect that
change (of course it usually doesn’t make any sense to edit a summary value like this). In the illustration
shown below the summary value has been increased from 21908.19 to 27908.19.

We’re finished with the chart, so close the window. Choose Restore Original Data from the Action menu,
then Save the database. To learn more about charts see “Charts” on page 993 of the Panorama Handbook.
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Data Entry Helpers

Now let’s switch gears. Before you can analyze data you have to get the data into the database, and that usu-
ally means data entry with the keyboard. This job is never easy, but Panorama does have tools that can make
data entry faster and less error prone. The next few sections will look at how the data entry process can be
improved for each of the fields in the checkbook database.

Dates

The first field in the database contains the check date. You can modify the way dates are displayed. Start by
clicking anywhere in the Date field and then choose the Field Properties dialog from the Fields menu (see
“Modifying the Properties of an Existing Field” on page 195 of the Panorama Handbook). (You can also open
this dialog by double clicking on the field name at the top of the column.) The Field Properties dialog allows
you to modify many of the attributes of each field. The New Database Wizard has already set up some of the
options in this dialog, including the Field Name, Type and Default Value.

field name

field type

default value
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To change the output pattern, click on the icon and choose the option you want.

After you select the option press the OK button to get back to the data sheet. The dates are now displayed
with your selected pattern.

The pattern can be changed at any time.

click here to change pattern
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The New Database Wizard automatically set this date field to default to today’s date. To see this in action,
press the Add New Record tool (or select Add New Record from the Records menu).

The new check automatically defaults to today’s date.

Smart Dates

Panorama is very flexible about how you type dates. We call this feature “smart dates.” You can enter dates
numerically (for instance 04/09/02 or 4/9/2) or you can spell out the date (for instance April 9th, 1997 or Apr 9
97). You can use any character as a separator between numeric dates, for example 4-9-01 or even 4.9.01.

To enter today’s date, simply type today. You can also enter yesterday or tommorow. Panorama will auto-
matically convert these entries to the correct month, day and year.

If the date is in the current week, you can simply type in the name of the day, for example saturday or tue. To
specify a day in the previous or upcoming weeks add the words last or next, for example next tuesday or last
saturday.

Play around with entering different dates, then use the Cut Record tool to delete the new record.

Type… Date Entered
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Check Number

The second field contains the check number. You can modify the Field Properties to automatically add one to
create a new check number each time a new check is created. Click anywhere in the Check column and then
choose the Field Properties dialog from the Setup menu (see “Modifying the Properties of an Existing Field”
on page 195 of the Panorama Handbook). (You can also open this dialog by double clicking on the field name at
the top of the column.) The New Database Wizard has already set up some of the options in this dialog,
including the Field Name and the Type.

To set up the default value for this field, click on the icon and choose the option you want.

Choosing Automatic increment by one sets the default value to +1.

field name

field type

click here to change default value

or you can type in the default value here
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Press the OK button to get back to the data sheet. Then press the Add New Record tool (or select Add New
Record from the Edit menu).

The new check automatically defaults to today’s date and is assigned the next check number, in this case 562.

Pay To

The third field contains the name of the person or company the check is made out to. Since you will often
write checks out to the same people over and over again you can take advantage of a very cool Panorama fea-
ture called Clairvoyance®. Clairvoyance automatically finishes your typing for you as soon as it thinks it can
identify what you are about to type based on the previous entries (see “Clairvoyance®” on page 284 of the
Panorama Handbook). Clairvoyance can be turned on and off with the Field Properties dialog. Click anywhere
in the Pay To column and then choose the Field Properties dialog from the Setup menu (see “Modifying the
Properties of an Existing Field” on page 195 of the Panorama Handbook). (You may have also heard that you
can open this dialog by double clicking on the field name at the top of the column. It’s really true!). The New
Database Wizard has already set up some of the options in this dialog, including the Field Name and Type.
Use pop-up menu to turn on the Auto Capitalize option, and the checkbox to turn on the Clairvoyance
option, as shown below.
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Press OK to close the dialog. Now try entering Blue Cross into the Pay To data cell. Leave your finger off the
Shift key as you type because Panorama will automatically capitalize the first letter of each word for you! As
soon as you press the letter l, Panorama’s Clairvoyance® feature will complete the entry for you by typing ue
Cross.

Clairvoyance automatically finishes your typing for you as soon as it thinks it can identify what you are
about to type based on the previous entries. If Clairvoyance guesses wrong (because this is a new entry that
hasn’t appeared before) just keep typing and complete the entry yourself.

Clairrows

When you hold down the Command key (Mac) or Control key (Windows), the up and down arrows on the
keyboard become clairvoyant arrows, or “clairrows.” With the key held down you can use the arrows to scan
through the values that are already in the database. Each time you press Command/Control-Down Arrow
the next value appears, while each time you press Command/Control-Up Arrow the previous value appears.
You can scan through the values until you find the information you are looking for, then press the Enter key
to enter the value. To give the clairrows a head start you can type in the first few letters of the information
you are looking for. 

B is automatically capitalized for you because of Auto Capitalize option

Clairvoyance automatically completes the entry for you

type   b

l
Cmd/Ctl-Down Arrow

Cmd/Ctl-Down Arrow

Cmd/Ctl-Down Arrow

Cmd/Ctl-Up Arrow

Cmd/Ctl-Up Arrow

Enter
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Category

The Category field places each check into one of 11 categories (Rent, Insurance, Telecom, etc.) One way to
handle this field would be to use Clairvoyance® as described for the Pay To field. That way you would only
have to type in the first letter or two of the category. However instead of using Clairvoyance you are going to
set up a palette of radio buttons in the pop-up Input Box (see “The Choice Palette” on page 317 of the Pan-
orama Handbook). This palette will have a radio button for each category. This palette is set up with the
Choices option in the Field Properties dialog.

To manually set up choices simply type in each choice, separated by a space (if a choice contains a space use
an underscore instead, for example New_York). However since this database already contains data, Pan-
orama can fill in the choices for you. Simply press the Auto button to fill in the choices that already exist in
the data.

Click the Auto button…

The choices are automatically filled in
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Press the Ok button to close the Field Properties dialog and go back to the data sheet, then double click on the
empty data cell at the bottom of the Category column. The Input Box will appear, but it is so small you can
only see the first button and part of the second.

Move the mouse to the bottom right corner of the Input Box. The cursor will flip over (see “Expanding the
Input Box” on page 273). Drag the mouse to expand the Input Box.

The radio buttons will automatically flow into the expanded box as you change its shape.

The box can be tall and skinny, short and fat, or anything in between. To select a value just click on the button
and press Enter or Tab, or simply double click on the button. You can also select a value by typing in the first
few letters of the value, for example U for Utilities or Pu for Purchases.

The radio buttons are great if you want to select from one of the predefined categories, but what if you want
to add a check in a new category? To allow this you’ll need to go back to the Field Properties dialog and type
a space and a dozen underscores at the end of the list of choices. (The underscore is just to the right of the 0
key, hold down the Shift key and press -).
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Press OK to close the dialog and go back to the data sheet, then double click on the Category field.

It looks just the same as before! What’s up with that? To find out, expand the Input Box just a little bit more.

Now you can see that there is one additional radio button at the end of the list. To enter a new category click
on this radio button and then type in the new category, in this case Auto.

Press the Enter key when the entry is completed.

To learn more about this feature see “The Choice Palette” on page 317 of the Panorama Handbook. Before going
on to the next step I recommend that you Save the database one more time.
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Looking Up the Category From a Previous Record

In this database a particular Pay To will almost always go with a particular category. For example the cate-
gory for checks to Blue Cross will always be Insurance, while the category for Staples will always be Office
Supplies. Panorama can be set up to use a formula to automatically look up the category from the previous
record, if any. To do this you’ll use the Field Properties dialog again. Click on the Category field, then open
the Field Properties dialog, then choose Assistant from the Formula menu.

This assistant lists thousands of items. To find the one needed, type lookuplast( into the search box, then dou-
ble click on the lookuplast( line (or simply press the Insert button).

1) Type lookuplast( into search box

2) Double click on lookuplast( line
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Double clicking this item (or pressing Insert) closes the Programming Assistant dialog and opens a dialog for
setting up the lookup( function (see “Linking With Another Database” on page 131 of Formulas & Program-
ming).

Start by selecting the database you want to look up data from, in this case the current database.

Now tell Panorama what you want to look up, in this case the Category.

We want to look up the category in the last record in the database where the Pay To value matches the Pay To
value in the current field. So select Pay To for both of the last two pop-ups. Here’s the finished dialog with
everything filled in.
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Press the OK button to build the formula for looking up the previous category. The formula is automatically
placed into the Field Properties dialog, which is still open.

To learn more about how this formula works see “Linking With Another Database” on page 131 of Formulas
& Programming. For now just press the Ok button to go back to the data sheet. Then start typing Staples into
the Category field.

When you press the Enter key Panorama will automatically look up the appropriate category, in this case
Office Supplies.
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Sometimes the check amount is the same from check to check also, for example a rent or subscription pay-
ment. You can go back to the design sheet and use the same technique to build a formula to look up the pre-
vious check amount. The formula is almost the same as before, but this time it looks up the Debit field and
has a default value of 0 instead of "" (see “Linking With Another Database” on page 131 of Formulas & Pro-
gramming).

Press the Ok button to close the dialog and go back to the data sheet, then start typing Pacific Properties into
the Category field.

When you press the Enter key Panorama will look up both the category and the amount from the previous
check to Pacific Properties.

If this isn’t the correct amount you can simply tab over to the Debit field and type in the actual amount. If you
haven’t done so already, Save the database again now.
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Calculating the Checkbook Balance

Calculating the running checkbook balance is a two step process. Since you will probably want to do this
multiple times, recording a procedure is a good idea. Start by turning the recorder on (see “Creating a Proce-
dure with the Recorder” on page 212 of Formulas & Programming).

Scroll over to the Balance field and click somewhere in the field.

Now choose the Manipulate Data in Field command from the Fields menu, then use the pop-up menu to
change the Start with Field from Balance to Credit.

change from Balance to Credit

then press the + button
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Next, press the + button to add another row. Then use the pop-up menus to set up the calculation as shown
below. 

When you press the Apply button Panorama will perform this calculation over and over again for every
record in the database.

change Add Number to Subtract Field change Balance to Debit
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To complete the balance calculation choose the Vertical Data Tabulation command from the Fields menu.
Then click on the Running Total option.

Then press the Apply button to calculate the balance after each check or deposit.
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The balance calculation is complete, but remember that all this is being recorded? To finish the recording
select the recorder tool again.

Pick a name for the new procedure and type it in, then press the Create Procedure button.

Now any time you need to update the checkbook balance you can simply select your new procedure from the
Action menu.

If you are curious to see what the code in your new procedure looks like you can use the View menu to open
it.

Before moving on to the next step it’s a good idea to… you guessed it, Save the database.
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Drawing a Check Form

To complete your check database you’ll create a check form that can be used for data entry. If you are using a
Windows PC hold down the Alt key, if you are using a Macintosh hold down the Control key. Either way,
select New Form from the View menu (see “Creating a New Form” on page 487 of the Panorama Handbook).
Type in the name of the new form (up to 25 characters).

Press the Blank Form button to create the new form, then adjust the window to the approximate size of a
check.
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Now choose the Form Preferences… command from the Setup menu and use the pop-up menu to set the
form’s background color to light green.
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Before you actually start building the form you need to customize the graphic tool palette. Use the Tool Pal-
ette command in the Setup menu to open the tool configuration dialog.
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There are a total of 29 graphic tools available for use in Panorama (shown in the list below on the left). Many
computer screens are not large enough to handle this complete palette of tools (and we expect the number of
tools to increase in future versions). To get around this problem, Panorama allows you to customize the
graphic tool palette on the fly (see “Customizing the Tool Palette” on page 497 of the Panorama Handbook).
You can configure the palette to contain only the tools that you need right now in any order you want. If your
needs change later, you can simply reconfigure the palette at any time.
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On the right is a list of the tools you currently have installed. If this list is empty, Panorama will use the
default tool palette. To move a tool from the left to the right, double click on the tool in the left. Or you can
select the tool (or tools) and press the Move or Insert button. Move the nine tools shown below into the list
on the right.

When you press the OK button the tool palette in the form will be updated.



Page 171
Creating the Text Editor SuperObjects

Using the Text menu or the Graphic Control Strip set the text size to 9 points (see “Text Font, Size and Style”
on page 593 of the Panorama Handbook).

With the Pointer tool selected, click the mouse in approximately the location shown below.
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Now select the Auto Cell Layout command from the Arrange menu (see “Automatically Creating Rows or
Columns of Data Cells or Text Editor SuperObjects” on page 662 of the Panorama Handbook). You used this
command in your My Mailing List database to create data cells, now you’ll use it to create Text Editor Super-
Objects (see “Types of Data Editing Objects” on page 632 of the Panorama Handbook).

Start by holding down the Shift key and clicking on each of the first six fields.
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Next click on the Create SuperObjects™ and 3D checkboxes.

Press the OK button to create the Text Editor SuperObjects.

Text Editor SuperObjects may be used as an alternative to data cells for editing text within a form. You can
already see one difference between these two types of objects — the Text Editor SuperObject displays data
even in Graphic Design Mode, not the field name. To see the major difference between these two types of
objects switch the form to Data Access Mode (see “Form Modes: Data Access vs. Graphic Design” on
page 485 of the Panorama Handbook).
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Text Editor SuperObjects allow you to edit text right in the form window—no double click is required. You
can simply click or drag on the text to begin editing. Press Enter when you are finished. The illustration
below shows the effect of double clicking on the word Poly. As you can see, instead of opening an Input Box
this selects the word for editing.

Since the Text Editor SuperObject doesn’t use an Input Box, you cannot expand the size of the editing area
“on-the-fly” the same way you can with data cells. The editing area must be defined in advance. On the other
hand, the Text Editor SuperObject doesn’t require the extra double click, and works more like other standard
applications you may be used to. See “Creating and Modifying Text Editor SuperObjects” on page 639 of the
Panorama Handbook to learn more about Text Editor SuperObjects. For now, however, switch the form back to
Graphic Design Mode so that you can continue designing your new form.

Dressing Up the Check Form

Select the Rectangle tool and draw a rectangle next to the check date (see “Creating a Graphic Object” on
page 494 of the Panorama Handbook).

Change the Fill Pattern of the rectangle to solid black (see “Fill Pattern” on page 521 of the Panorama Hand-
book).

Select the Text tool and create a click-text object that says Date. (see “Fixed Text Objects” on page 587 of the
Panorama Handbook).
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Select the Pointer tool and then click on the new text object.

Use the Graphic Control Strip to set the text color to light yellow (see “Color” on page 526 of the Panorama
Handbook).

Drag the text over the black box.

Adjust the black box and the text until they line up with the Text Editor SuperObject as shown below. To
adjust these objects you can drag them (see “Moving a Single Object” on page 508 and “Changing the Size of
a Single Object” on page 513 of the Panorama Handbook) and nudge them with the arrow keys (see “Nudging
an Object (or Objects)” on page 509 and “Nudging the Size of an Object” on page 513 of the Panorama Hand-
book).
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Drag a marquee around these objects to select them (see “Selecting Multiple Objects at Once” on page 502 of
the Panorama Handbook).

Then drag the objects into the upper left hand corner of the form.

Now drag a marquee just around the box and text objects.

Hold down the Shift and Option keys on the Mac, or Shift and Alt keys on the PC. With these two keys held
down drag the two objects to the right.

Holding down the Shift key insures that you drag the objects at 90 degrees, either perfectly up and down or
perfectly left and right (as in this case). Holding down the Option/Alt key tells Panorama to duplicate the
objects. When you release the mouse you’ll have two copies of these objects.
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Select the Text tool and click on the new text object.

Edit the text to say Number instead of Date.

Select the Pointer tool and adjust the rectangle size to match the new text.

Drag the check number up next to these objects.

Using the techniques you’ve just learned continue re-arranging the form until it looks like this.
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Make a copy of the Pay To caption.

Change the text to Memo and expand the rectangle to about 1 inch high.

Slide and resize the memo field itself into place.



Page 179
To add a scroll bar to the memo field double click on the Text Editor SuperObject to open the object properties
dialog. This dialog lets you turn various object options on and off. Click on the Vertical Scroll Bar checkbox.

When you press the OK button the memo field gets a vertical scroll bar.
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To actually use the form you must switch into Data Access Mode. Notice that the background of the field
being edited turns white (in this case the memo field).

Use the Tab key to move from field to field.
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Making the Form Elastic

An ordinary form is fixed — it stays the same no matter what the size of the window is. By adding a single
object to your form you can make it elastic. An elastic form adjusts automatically to fit the window — it
grows when the window grows and shrinks when the window shrinks. Start by switching back to Graphic
Design Mode. Then double click on the memo field to open the object properties dialog.

Turn on the Grow Box option, then press the OK button. The memo field now reserves a spot for the win-
dow’s grow box.

corner reserved
for grow box
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Using the Rectangle tool draw a box in the spot reserved for the grow box.

Using the Duplicate command in the Edit menu, make a copy of the box (see “Duplicate” on page 561).

Set the Fill Pattern of the new box to solid black (see “Fill Pattern” on page 521).

Set the color of the new box to the same green color as the background (see “Color” on page 526).

Use the arrow keys to nudge the green box until it covers the white area but leaves the black border.

Now to make the form elastic. Start by selecting the Auto Grow tool. (If you can’t find the Auto Grow tool
you need to customize the tool palette. See “Customizing the Tool Palette” on page 497 of the Panorama Hand-
book.)
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Starting from the bottom right hand corner of the form, drag the mouse up and to the left. Release the mouse
somewhere between the left edge of the Category field and the right edge of the Pay To field, as shown in the
illustration below. (The blue and green lines in the illustration below have been added to highlight the loca-
tion of these edges.)

When you release the mouse the Auto Grow configuration dialog appears. The dialog is already filled out for
you except that you need to turn on the Draw Grow Icon checkbox.

Press the OK button to finish creating this object.

auto-grow object
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The auto-grow object is covering up some of the memo field. To fix this use the Send To Back command in
the Arrange menu (see “Changing the Stacking Order” on page 569 of the Panorama Handbook).

When you switch the form to Data Access Mode the auto-grow object completely disappears.

But the real fun starts when you adjust the size of the window. The form adjusts automatically to the new
size! See “Elastic Forms” on page 922 of the Panorama Handbook for a complete explanation of how this magic
works.
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To get rid of the extra scroll bars and tool palette choose the Window Tweak command from the Form Tools
submenu of the Wizard menu (see “Turning Window Components On and Off (Window Tweak Wizard)” on
page 150 of the Panorama Handbook).

In this case you may want to use the tool palette. To get it back uncheck the Tool Palette option in the Window
Tweak window.

Then press the Tweak button twice. Here’s the final result.

Oh yeah, one more thing. You have been remembering to Save, right? Well, go for it now, and you’re done.
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Lesson 3: Building an Invoice Database
Invoice

Now that you’ve mastered basic skills in building databases, forms and procedures you’re ready to tackle a
more complicated task. Organizing invoices (or similar forms like statements, purchases, quotes, expense
reports etc.) is one of the most common jobs performed by database programs. Just as with the databases in
the earlier two lessons you’ll start by launching Panorama and the New Database Wizard. Instead of build-
ing this database from scratch you’re going to use the pre-built Invoice favorite. To do this click on the yellow
star and choose Invoice.
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When you select this template the wizard will call up a list of definitions for the twenty fields required for an
invoice, including default values and calculations.

Press the Make New Database tool to actually create the database. Since this database contains line items,
Panorama will ask you how many line items you want. By default the wizard will create a database that
allows up to six line items per invoice. Let’s increase this to twelve line items per invoice
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The new database has so many fields that we can only see a small portion of them at once using the data
sheet. In a moment we’ll create a form that is much better suited to displaying this data. 

Before going any further you should Save the new database. Give it the name My Invoices and save it in the
same folder as your first two databases. Be sure to check the Save Window Positions option in the Save As
dialog if it isn’t already checked.
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Line Item Fields

The New Database Wizard invoice template contained 20 fields. However, if you look in the design sheet (use
the View menu) you will see that the database actually contains 64 fields.

The solution to this mystery is that four of the fields in the template, QtyΩ, ItemΩ, PriceΩ and AmountΩ, are
actually a special kind of field called line item fields. The wizard expanded each of these into 12 fields, Qty1,
Qty2, Qty2, etc., Item1, Item2, Item3, etc. This allows the invoice to contain information about up to 12 sepa-
rate items. It’s difficult to work with so many fields in the data sheet view, so you’ll create a form that allows
you to display and edit the data in a format that looks like a traditional paper invoice.
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Creating an Invoice Form

You already know how to create a new form, so make one named Order Entry. There’s no need to open it in a
separate window, you won’t be needing the data sheet again.

Using the techniques you’ve learned make the form look like the illustration below. If you need to review
these techniques see “Creating a Data Entry Form” on page 62 and “Drawing a Check Form” on page 166.
You may find it easier to switch the rulers to pixels instead of inches as shown in the illustration below, see
“Rulers” on page 506 of the Panorama Handbook to learn how to do this.

click text object

rectangle

data cell

all text is 9 point

pixels
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Adding Line Items to the Form

The heart of the order entry form is the line items. This section of the form will contain 56 objects — 48 data
cells (4 columns by 12 rows) plus 4 text objects and 4 rectangles for column captions. Fortunately the Auto
Cell Layout dialog will create most of these objects for you automatically. You’re going to create the line
items in the blank area to the right of the objects you’ve already created. Start making sure that black is the
currently selected color (see “Color” on page 526), then click the mouse in the upper left hand corner of this
blank area.

Now choose the Auto Cell Layout command from the Arrange menu. You’ve seen this dialog before. Since
we want to create line items press the Line Items button. This selects all of the line item fields.



Page 192 Panorama Tutorial
You don’t need to change any of the other options, just press the OK button. Panorama will automatically
create all 48 data cells you need in 12 rows by 4 columns.

You’ll need to make some adjustments to make the line items look right in your invoice. Start by choosing the
Spacing command in the Edit menu (see “Adjusting Spacing Between Multiple Objects” on page 556 of the
Panorama Handbook).
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Click the Vertical option and type in 1 for the pixel spacing. Then press OK to adjust the vertical spacing
between the lines. There is now one pixel in between each line.

Next you’ll want to adjust the width of the columns, starting with the Item column. To adjust the width,
move the mouse over the lower right hand handle of one of the objects in the column, then press and drag to
the right. Hold down the Shift key to make sure that you don’t change the height of the object, only the
width. If you hold down the S key (the letter S) you don’t have to exactly press on the handle itself, any-
where close to the bottom right hand corner of the object will do (see “Resizing Without Handles” on
page 516 of the Panorama Handbook).
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When you release the mouse all of the selected objects will adjust to the new width (see “Cluster Resize” on
page 541 of the Panorama Handbook).

Repeat as necessary until all the widths look the way you want. You can also nudge the widths with the
arrow keys for fine adjustments (after dragging the width, see “Nudging the Size of an Object” on page 513
of the Panorama Handbook).

While holding down the Option key (Macintosh) or Alt key (PC) drag the small purple rectangle next to the
Date cell over the Qty1 text.

When you release the mouse there will be a new purple rectangle covering the text.



Page 195
Adjust this rectangle so that it exactly covers the Qty1 text (see “Nudging the Size of an Object” on page 513
of the Panorama Handbook).

While holding down the Shift key and the Option key (Mac) or Alt key (PC) drag this rectangle to the right
over the Item1 text.

Adjust this new rectangle so that it covers the Item1 text.

Repeat for the Price and Amount columns.

While holding down the Shift key, click on each of the four purple rectangles you just created. This selects all
four objects (see “Selecting Multiple Objects at Once” on page 502 of the Panorama Handbook).

hold down SHIFT key and click on each object you want to select
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Now choose the Send to Back command from the Arrange menu (see “Changing the Stacking Order” on
page 569 of the Panorama Handbook).

Using this command moves the four purple rectangles behind the four text objects, making the text objects
visible again (see “Overlapping Objects” on page 568 of the Panorama Handbook).

Because the text objects are black on a purple background they aren’t very easy to see. To change that, start by
clicking on an empty spot on the form. Clicking on an empty spot makes sure that the four purple rectangles
are no longer selected.

click on any empty spot to make sure that no objects are selected
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Now hold down the Shift key and click on each of the four text objects. With the four objects selected change
the color to light blue to match the other caption text (see “Color” on page 526 of the Panorama Handbook).

The text will turn light blue, almost white.

The annoying white border around the text objects is because these are auto-wrap text objects (see “Fixed
Text Objects” on page 587 of the Panorama Handbook). The border will go away when you switch to Data
Access Mode. However, we are going to convert these objects from Auto Wrap text into Click text. To do this
drag the lower right hand handle of the object up over the upper right hand handle (see “Moving and Resiz-
ing Fixed Text Objects” on page 590 of the Panorama Handbook).

hold down SHIFT key and click on each object you want to select
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When you release the mouse the text is converted into click text, and the annoying border disappears.

Repeat this conversions for each of these four objects.

Now select the Text tool and edit the text to remove the 1 from the end of each object.

Switch back to the Pointer tool and drag a marquee around all of the line item objects (see “Selecting Multiple
Objects at Once” on page 502). Because of the arrangement of objects in the form it is probably easiest to do
this from the bottom right to the upper left.

converted to click text
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Now nudge the objects into alignment with the objects on the left hand side of the form (see “Nudging an
Object (or Objects)” on page 509 of the Panorama Handbook).

Now you need to create the data cells for the subtotal, tax, shipping and grand total. Start by clicking on an
empty spot on the form (to make sure no objects are selected) and then drag a marquee around the Amount9
through Amount12 data cells.

While holding down the Shift key and the Option key (Mac) or Alt key (PC) drag these four rectangles down
below the other line items (see “Drag Duplicating” on page 561 of the Panorama Handbook).
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Use the up arrow key to nudge the objects so that they are snuggled up with the Amount12 cell, then select
the Data Cell tool.

Move the mouse over the new Amount9 data cell you have created. The mouse arrow will turn into a tiny
menu icon (see “Working with Data Cell Objects” on page 635).
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Press the mouse and select SubTotal from the pop-up menu.

When you release the mouse the data cell will be assigned to the SubTotal field.

Repeat this for each of the other three data cells.
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Since you’re pretty much a professional by now you should have no problem finishing up this form so that it
looks like this.

Be sure to Save this masterpiece before you go any further.

Entering Data into the Invoice

Before you can enter data into the invoice you must switch to Data Access Mode. You may also want to adjust
the size of the window to match the size of your form.

As you start typing data you’ll quickly discover a problem. Pressing the Tab key after you enter the name
causes Panorama to tab into the first Qty line item instead of the Company field. Oops!
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To fix this problem switch back into Graphic Design Mode. While holding down the Shift key click on the
Name, Company, Address, City, State, Zip, Country, Phone and Memo data cells 

Now select the Group command from the Arrange menu.

This command combines the nine objects into one combined object (see “Grouping Objects Together” on
page 536 of the Panorama Handbook). Instead of having handles around each individual object (see illustration
above) there are now only four handles around the four corners of the combined object.

handles for group object
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Now each time you press the Tab key Panorama will advance to the next cell within the group (see “Tab
Order in Forms” on page 670 of the Panorama Handbook).

The next tab will bring you to the first line item field. Enter the quantity, item and price.

When you press the Enter key Panorama will calculate the line item total, subtotal, tax and grand total.

These calculations were set up for you by the New Database Wizard. To learn how to set up or modify these
calculations yourself see “Automatic Calculations” on page 303 of the Panorama Handbook.
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Lesson 4: Building a Price List

Now that the invoice is complete you will build a price list database and link the price list to the invoice. Start
by launching Panorama and the New Database Wizard. The price list database will have two fields — Item
and Price, so fill in the wizard as shown below.

When you press the Make New Database button the wizard will create a new database for you, then it will
offer to pre-fill the database with sample data. Press Yes and the new database will appear, complete with
data.
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Before continuing you should use the Save command in the File menu to save your new creation. The first
time you save any file Panorama will ask you to give it a name. When everything is set up press the Save but-
ton. (To see what this dialog looks like on the PC see “Saving Your Work” on page 12.)

select folder you want to save file in
type in name of file

tell Panorama to save window positions
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Linking the Price List to the Invoice

The price list is now ready to link to the invoice. The link will be designed to look up a price automatically
when an item is entered into the invoice. Start arranging the invoice and price list windows so that both are
visible, with the invoice window on top (something like the illustration shown below). 

Using the View menu, switch from the invoice form to the invoice design sheet (see “The Design Sheet” on
page 212 of the Panorama Handbook).
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Double click on the Equation cell in the Price1 row.

Now choose lookup(…) from the Functions menu (see “Functions Menu” on page 45).
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Choosing this menu item opens a dialog for setting up the lookup( function (see “Linking With Another
Database” on page 131 of Formulas & Programming).

Start by selecting the database you want to look up data from, in this case the My Price List database.

Now tell Panorama what you want to look up, in this case the Price.
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We want to look up the price where the Item in the price list matches the Item value in the invoice. So select
Item from My Price List.

Select Item1 for the last pop-up.



Page 211
Here’s the finished dialog with everything filled in.

Press the OK button to build the formula for looking up the price.

To learn more about how this formula works see “Linking With Another Database” on page 131 of Formulas
& Programming. The formula generated by the dialog needs one slight adjustment — Item1 must be replaced
by ItemΩ. To type the Ω character use Option-Z on the Macintosh and Alt-0166 on the PC (see “Special
Characters” on page 57 and “Line Item Fields” on page 52 of Formulas & Programming).
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Once this adjustment has been made press the Enter key. Panorama will respond with this dialog (see “Mod-
ifying Line Item Fields” on page 225 of the Panorama Handbook).

Press the Yes, and don’t ask me again button. Panorama will update not only the Price1 field definition, but
also Price2, Price3, Price4 etc. You can see this by scrolling down the design sheet. (We’ve split the window
into two panes (see “Splitting a Window” on page 145 of the Panorama Handbook) and expanded the width of
the Equation column to make this easier to see.)

Now click on the Item1 field name (we’ve also unsplit the window and reduced the width of the Equation
column).
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Choose the Set Up Link command from the Special menu (see “Clairvoyance® Across Multiple Files” on
page 286 of the Panorama Handbook).

On the left hand side select My Price List. Then select Item on the right hand side (as shown above).

Press OK to set up the link.

The link must be copied to all of the other item fields (Item2, Item3, Item4, etc.) To do this, double click on the
link.
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When you press the Enter key the link specification will be copied to all of the other Item fields.

Use the View menu to switch back to the Order Entry form. When Panorama asks you if you want to create a
new generation, press the Yes button (see “Database “Generations”” on page 212 of the Panorama Handbook).
Then Save the database before continuing.

Using the Linked Invoice & Price List

Since you’ve set up a Clairvoyant link between the invoice and the price list you’ll only need to enter the first
few letters of a description.
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When you press the Enter key Panorama will look up the price from the Price List database. Once the price is
looked up Panorama will then automatically calculate the subtotal, tax and grand total.

You can enter up to 12 items in each invoice.
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Creating a Procedure to Add an Item

Now you’ll write a very short procedure. Start by clicking on the Price List database.

Use the View menu to create a new procedure named Add Item to Invoice (see “Writing a Procedure from
Scratch” on page 216 of Formulas & Programming). Type in the four lines shown below, exactly as they are
shown. (Remember, the Ω character is typed in by pressing Option-Z on the Macintosh or Alt-0166 on the
PC. Depending on the fonts installed on your system the character may not look like Ω, but it will work if you
press the right keys.)

To check your typing use the Check Procedure tool. This tool can spot most typing mistakes (see “Checking
for Mistakes” on page 220 of Formulas & Programming).
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Assuming there are no errors use the View menu to switch back to the data sheet. (If there are any errors - fix
them!) Then pick the item you want to add to the invoice and choose Add Item to Invoice from the Action
menu.

The procedure will automatically add the selected item to the invoice.

To learn more about how this procedure actually works see “Assignment Statements” on page 243, “Win-
dows” on page 445 and “Moving Left and Right” on page 515 of Formulas & Programming.

Creating a Price List Form with Buttons

Now you’ll create a price list form with buttons for adding items to the invoice. Start by using the View menu
to create a new form named Add.
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You’re going to make a View-As-List form (see “View-As-List Forms” on page 899 of the Panorama Hand-
book). To do this start by selecting the Tile tool. You may need to scroll the tool palette to access this tool (see
“Scrolling the Tool Palette” on page 143 of the Panorama Handbook).

Expand the width of the window slightly, then drag the mouse across the form to create a tile (see “Working
with Tiles” on page 908 of the Panorama Handbook).

When you release the mouse a new data tile appears.
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Before you continue with the next step you’ll need to customize the tool palette. To do this choose Tool Pal-
ette from the Setup menu and then arrange the tools as shown below (see “Customizing the Tool Palette” on
page 497 of the Panorama Handbook).

Press the OK button, then select the Push Button tool (see “Push Buttons” on page 823 of the Panorama Hand-
book).

Now drag to create a button in the upper left hand corner of the data tile.
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Now you’ll need to select three options for the new push button. Using the pop-up menu select the proce-
dure linked to this button, in this case Add Item to Invoice. (This means that when this button is pressed the
Add Item to Invoice procedure will be triggered, just as if you had selected it from the Action menu.) Type in
the title you want to appear in the button, in this case Add. Click on the button style you want to use, in this
case 3D Rounded Rectangle.

When you press the OK button the new push button will appear on your form.

Select the Pointer tool and adjust the text size and overall dimensions of the button (see “Text Size” on
page 531).
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Now select the Text Editor tool (see “Text Editor SuperObject” on page 639 of the Panorama Handbook).

Drag the mouse to create a text editor object.

When you release the mouse the Text Editor SuperObject configuration dialog appears (see “Text Editor
Options” on page 643 of the Panorama Handbook). Set the options as shown in the illustration below.
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When you press the OK button the new Text Editor SuperObject will appear.

Select the Pointer tool and adjust the size and position of the new object (see “Nudging the Size of an Object”
on page 513 of the Panorama Handbook).

Hold down the Option key (Mac) or the Alt key (PC) and drag the Text Editor object to the right (see “Drag
Duplicating” on page 561 of the Panorama Handbook).

Adjust the size of the new object and select the Right command from the Text menu (see “Text Alignment” on
page 594 of the Panorama Handbook).

Double click on the new text editor object (see “The Object Properties Dialog” on page 534 of the Panorama
Handbook) and change the field to Price.
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Press OK to update the object.

Click in the tiles’ drag bar to select it (see “Working with Tiles” on page 908).

Use the color menu to change the tile to light gray.

Drag the lower left hand handle of the tile up until there is an equal margin around the button and text editor
objects.
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The finished form should look something like this.

Using the Form Preferences dialog in the Setup menu, change the viewing format for the form to View-As-
List.

Press the OK button, then switch back to Data Access Mode.
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Here’s what the form should now look like in Data Access Mode. The graphics on the tile are repeated over
and over again for each record in the database.

To add a particular item to the current invoice just click on the Add button for that item.
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Clicking this button will trigger the procedure which adds the item to the invoice.

Now Save both databases and you are done.
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Saving a File Set

Before continuing, make sure that the My Invoice and My Price List files are the only two databases open in
Panorama. Then choose the File Save command from the File menu. Type in the name of the file set you want
to create (in this case Order Entry) and click on the Set option.
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If you are using a Windows PC computer use the combo box to choose the Panorama File Set {*.pnz} option

Press the Save button to create the file set document.

Later if you want to open both the My Invoices and My Price List files together you don’t need to open them
separately. Instead you can simply double click on the Order Entry icon, and Panorama will open both files
automatically. See “File Sets” on page 75 of the Panorama Handbook to learn more.
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